Bug 794690 - PulseAudio fails to run if ConsoleKit is not present, and CK is not included currently in F17 desktop live image
PulseAudio fails to run if ConsoleKit is not present, and CK is not included ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 795881 (view as bug list)
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-02-17 05:27 EST by Michael Schwendt
Modified: 2012-03-06 15:32 EST (History)
10 users (show)

See Also:
Fixed In Version: pulseaudio-1.1-8.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 15:32:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of "rm -rf ~/.pulse ; pulseaudio -vvv" (204.43 KB, text/plain)
2012-02-17 07:07 EST, Michael Schwendt
no flags Details

  None (edit)
Description Michael Schwendt 2012-02-17 05:27:18 EST
$ pulseaudio -k
E: [pulseaudio] main.c: Failed to kill daemon: No such process
$ pulseaudio -D
E: [pulseaudio] main.c: Daemon startup failed.
$ pulseaudio 
E: [pulseaudio] bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.systemd1.LoadFailed
E: [pulseaudio] module-console-kit.c: GetSessionsForUnixUser() call failed: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ConsoleKit was not provided by any .service files
E: [pulseaudio] module.c: Failed to load module "module-console-kit" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

In "Sound" settings, nothing can be configured. This is a machine that has worked fine with F-16 and older.

$ rpm -qa pulseaudio\* systemd\*|sort
pulseaudio-1.1-3.fc17.x86_64
pulseaudio-gdm-hooks-1.1-3.fc17.x86_64
pulseaudio-libs-1.1-3.fc17.x86_64
pulseaudio-libs-glib2-1.1-3.fc17.x86_64
pulseaudio-module-bluetooth-1.1-3.fc17.x86_64
pulseaudio-module-gconf-1.1-3.fc17.x86_64
pulseaudio-module-x11-1.1-3.fc17.x86_64
pulseaudio-utils-1.1-3.fc17.x86_64
systemd-43-1.fc17.x86_64
systemd-sysv-43-1.fc17.x86_64
Comment 1 Brendan Jones 2012-02-17 05:36:26 EST
Can you rm  ~/.pulse/*

and run pulseaudio -vvv and post the output here?
Comment 2 Michael Schwendt 2012-02-17 07:07:43 EST
Created attachment 563893 [details]
output of "rm -rf ~/.pulse ; pulseaudio -vvv"
Comment 3 Brendan Jones 2012-02-17 08:36:02 EST
Can you test for the presence of /usr/share/dbus-1/system-services/org.freedesktop.ConsoleKit.service (should be from ConsoleKit) ?
Comment 4 Michael Schwendt 2012-02-17 09:47:44 EST
# rpm -qf /usr/share/dbus-1/system-services/org.freedesktop.ConsoleKit.service
error: file /usr/share/dbus-1/system-services/org.freedesktop.ConsoleKit.service: No such file or directory
# ll /usr/share/dbus-1/system-services
total 104
-rw-r--r--. 1 root root 247 Jan 12 22:53 com.redhat.abrt.service
-rw-r--r--. 1 root root 242 Feb  3 16:35 fi.epitest.hostap.WPASupplicant.service
-rw-r--r--. 1 root root 232 Feb  3 16:35 fi.w1.wpa_supplicant1.service
-rw-r--r--. 1 root root  80 Jan 14 00:00 net.reactivated.Fprint.service
-rw-r--r--. 1 root root  95 Dec 30 12:44 org.bluez.service
-rw-r--r--. 1 root root 140 Jan 15 01:56 org.fedoraproject.Config.Firewall.service
-rw-r--r--. 1 root root 100 Jan 23 19:40 org.fedoraproject.Setroubleshootd.service
-rw-r--r--. 1 root root 123 Jan 23 19:40 org.fedoraproject.SetroubleshootFixit.service
-rw-r--r--. 1 root root 129 Jan 12 22:52 org.freedesktop.Accounts.service
-rw-r--r--. 1 root root 971 Jan 13 00:37 org.freedesktop.Avahi.service
-rw-r--r--. 1 root root 117 Jan 20 19:22 org.freedesktop.ColorManager.service
-rw-r--r--. 1 root root 410 Feb 15 04:57 org.freedesktop.hostname1.service
-rw-r--r--. 1 root root 406 Feb 15 04:57 org.freedesktop.locale1.service
-rw-r--r--. 1 root root 404 Feb 15 04:57 org.freedesktop.login1.service
-rw-r--r--. 1 root root  89 Feb  7 22:00 org.freedesktop.ModemManager.service
-rw-r--r--. 1 root root 459 Feb 16 04:16 org.freedesktop.NetworkManager.service
-rw-r--r--. 1 root root 101 Feb 16 04:16 org.freedesktop.nm_dispatcher.service
-rw-r--r--. 1 root root  89 Jan 27 18:39 org.freedesktop.PackageKit.service
-rw-r--r--. 1 root root 104 Feb 14 03:12 org.freedesktop.PolicyKit1.service
-rw-r--r--. 1 root root 833 Jan 14 22:37 org.freedesktop.RealtimeKit1.service
-rw-r--r--. 1 root root 355 Feb 15 04:57 org.freedesktop.systemd1.service
-rw-r--r--. 1 root root 410 Feb 15 04:57 org.freedesktop.timedate1.service
-rw-r--r--. 1 root root 123 Feb  7 16:15 org.freedesktop.UDisks2.service
-rw-r--r--. 1 root root  81 Jan 15 03:40 org.freedesktop.UPower.service
-rw-r--r--. 1 root root  99 Feb 14 06:01 org.gnome.GConf.Defaults.service
-rw-r--r--. 1 root root 110 Jan 13 05:06 org.opensuse.CupsPkHelper.Mechanism.service

# rpm -q ConsoleKit
package ConsoleKit is not installed

# yum list ConsoleKit
Loaded plugins: langpacks, presto, refresh-packagekit
Available Packages
ConsoleKit.x86_64                                                     0.4.5-2.fc17                                                      fedora
Comment 5 Brendan Jones 2012-02-17 09:54:54 EST
If you comment out these lines in /etc/pulse/default.pa does it start?

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif

Alternatively does installing Consolekit fix the issue?
Comment 6 Michael Schwendt 2012-02-17 09:56:33 EST
Re: ConsoleKit

Most recent NM update refers to "ConsoleKit" removal:
https://admin.fedoraproject.org/updates/FEDORA-2012-1807/NetworkManager-0.9.3-0.1.git20120215.fc17
Comment 7 Michael Schwendt 2012-02-17 09:57:07 EST
Re: comment 5

That results in:

$ rm -rf ~/.pulse ; pulseaudio 
E: [pulseaudio] bluetooth-util.c: Error from ListAdapters reply: org.freedesktop.systemd1.LoadFailed
E: [pulseaudio] socket-server.c: bind(): Address already in use
E: [pulseaudio] module.c: Failed to load module "module-esound-protocol-unix" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.
Comment 8 Brendan Jones 2012-02-17 11:54:30 EST
So the absence of ConsoleKit explains the first failure  that I can repeat here.
This is pulled in by KDE's network manager, so either it should be pulled into the defailt desktop or the default.pa that ships with pulse needs to be modified.

I can't reproduce the second error so am pulling down an RC2 now.  In the meantime can you attach the verbose output?
Comment 9 Brendan Jones 2012-02-17 12:53:13 EST
OK, running a live RC2 yields the consolekit error, but removing the module from /etc/pulse/default.pa fixes the issue here
Comment 10 Michael Schwendt 2012-02-17 13:01:29 EST
Confirmed. It's not so obvious.  I've restored the default default.pa, then installed ConsoleKit, and pulseaudio started to auto-spawn. Running "pulseaudio -k" said "Failed to kill daemon: No such process", and starting pulseaudio manually printed above error output. But actually pulseaudio started automatically and re-spawns automatically, too.  Hence I removed ConsoleKit* again, commented out the mod-consolekit entry in default.pa, and pulseaudio still starts automatically now.
Comment 11 Adam Williamson 2012-02-17 15:52:40 EST
Proposing as Alpha NTH and Beta blocker per Beta criterion "In most cases, the installed system must be able to play back sound with gstreamer-based applications". For NTH - this will affect the desktop live, so we can't entirely fix it with an update.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Brendan Jones 2012-02-18 10:08:47 EST
I think it makes sense to split this module off into a separate sub-package that requires ConsoleKit. That way the default.pa does not have to be changed. 
(this file is %config(noreplace) and will result in breakage if the module is present but no CK).
Comment 13 Brendan Jones 2012-02-22 11:24:30 EST
*** Bug 795881 has been marked as a duplicate of this bug. ***
Comment 14 Kevin Kofler 2012-02-23 12:07:39 EST
The fix is not to remove the functionality but to make it work with systemd's session tracking.
Comment 15 Adam Williamson 2012-02-23 12:17:35 EST
dropping it from the config file was meant to be a quick fix for alpha, but turns out we couldn't get it in in time because of the failure-to-compile problem.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Adam Williamson 2012-02-23 12:29:51 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Adam Williamson 2012-02-28 00:53:26 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Fedora Update System 2012-02-28 23:24:15 EST
pulseaudio-1.1-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pulseaudio-1.1-8.fc17
Comment 19 Fedora Update System 2012-02-29 13:53:20 EST
Package pulseaudio-1.1-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pulseaudio-1.1-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2698/pulseaudio-1.1-8.fc17
then log in and leave karma (feedback).
Comment 20 Kevin Kofler 2012-02-29 20:32:43 EST
The "Common F17 bugs" page claims this affects "Fedora 17 Alpha on all systems". But the F17 Alpha KDE spin does include ConsoleKit and as such should not be affected by this bug. (ConsoleKit won't be on F17 Beta KDE, but the changes implementing that did not make it into the Alpha.)
Comment 21 Adam Williamson 2012-03-02 02:18:15 EST
any time you come across an inaccuracy in the common bugs page, please do just go ahead and fix it. i don't consider it an 'owned' or 'immutable' page - it's just a normal wiki page, if you see something wrong, correct it! :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Kevin Kofler 2012-03-02 02:29:31 EST
The problem is that I'm not sure how to best reword it so that it is accurate without writing more about the technical details than the actual issue.
Comment 23 Adam Williamson 2012-03-02 13:18:52 EST
just something like 'note that KDE installations will not be affected by this issue, as ConsoleKit is still present in the default package set for KDE installations in Fedora 17 Alpha'.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 24 Adam Williamson 2012-03-02 13:19:57 EST
Discussed at 2011-03-02 blocker review meeting. Accepted as a Beta blocker per criterion "In most cases, the installed system must be able to play back sound with gstreamer-based applications (see Blocker_Bug_FAQ)".
Comment 25 Fedora Update System 2012-03-06 15:32:01 EST
pulseaudio-1.1-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.