Bug 7947 - sed breaks on and NFS partition
sed breaks on and NFS partition
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: knfsd (Show other bugs)
6.1
sparc Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-22 09:25 EST by Ken Filipps
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 10:45:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ken Filipps 1999-12-22 09:25:56 EST
This is a strange one...

I discovered while compiling a few packages for a new RedHat 6.1 (Sparc)
system I was setting up that running a 'configure' script on a piece of
software that the sed substitutions would fail when it was run on a NFS
mounted partition.  There was no problem on a local drive.  I have found
this with all packages I have tried.

However, I can read and write with no problems to the NFS mounted
partition.  There seems to be no issue with the partition.  I mount my
partitions from a Solaris 2.6 (Sparc) box.

Here is the tail end of a failed attempt (using screen-3.9.5 as an
example):

-----
updating cache ./config.cache
creating ./config.status
creating Makefile
sed: file conftest.s1 line 1: Unknown command: ``^''
creating doc/Makefile
sed: file conftest.s1 line 1: Unknown command: ``^''
creating config.h
sed: file conftest.frag line 1: Unknown command: ``%''
-----

I am stumped as to why these things should even be related...

My system is RedHat 6.1 with all relevent updates applied and my kernel is
a 2.2.12-42 stock kernel from the original install.
Comment 1 Jeff Johnson 1999-12-22 11:41:59 EST
If your promlem with sed disappears on local storage, but appears on NFS
mounts, then the problem is not with sed at all. NFS can and does inject blocks
of zeroes into files sometimes. I'm changing the component to knfsd. Supplying
a simple, reproducible test case will probably expedite a solution, but don't
be surprised if the problem cannot be reproduced in a different environment.
Comment 2 Alan Cox 2000-02-17 10:45:59 EST
Please apply the sun patchkits to the machine and see if you can
still reproduce the problem. There is a problem when certain
specific patterns of I/O occur and Solaris corrupts the data.

I don't know if that is your sed problem, but its a good first guess
Comment 3 Jeff Johnson 2000-10-07 10:28:33 EDT
Closed for lack of input.

Note You need to log in before you can comment on or make changes to this bug.