Bug 794744 - corosync doesn't utilize node id from configuration when using Infiniband transport
Summary: corosync doesn't utilize node id from configuration when using Infiniband tra...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-17 14:11 UTC by Jason Dillaman
Modified: 2013-02-21 07:50 UTC (History)
2 users (show)

Fixed In Version: corosync-1.4.1-8.el6
Doc Type: Bug Fix
Doc Text:
Cause Corosync with IBA transport. Consequence Corosync was always using autogenerated NodeID even if there were set one (in config file or by cman) Fix Don't ignore nodeid set by user. Result Corosync now autogenerated nodeid only when user didn't entered one.
Clone Of:
Environment:
Last Closed: 2013-02-21 07:50:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
Simple patch to fix the node id assignment for Infiniband (411 bytes, patch)
2012-02-17 15:07 UTC, Jason Dillaman
no flags Details | Diff
Patch from upstream git (1004 bytes, patch)
2012-02-22 09:52 UTC, Jan Friesse
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0497 normal SHIPPED_LIVE corosync bug fix and enhancement update 2013-02-20 21:18:24 UTC

Description Jason Dillaman 2012-02-17 14:11:25 UTC
Description of problem:
corosync ignores the cman-provided node id when using the Infiniband transport.  This prevents rgmanager from properly starting due to a failure message within DLM:

  dlm: Can't create listening comms socket
  dlm: cannot start dlm lowcomms -98  

corosync-cfgtool shows that the node ids appear to be automatically generated ids.  This prevents cman from retrieving node properties based upon the cman node id.  In the case of dlm, it is unable to query the IP addresses of the peer nodes.

Version-Release number of selected component (if applicable):
corosync-1.4.1-4.el6

How reproducible:
100%

Steps to Reproduce:
1.  Specify a nodeid and 'iba' transport iin "corosync.conf'.
2.  Start corosync and observe that the nodeid was ignored.
  
Actual results:
Corosync node ids are automatically generated instead of utilizing the assigned node id.

Expected results:
Corosync utilizes the assigned node id.

Workaround:
Configure cman's cluster.conf to utilize the same node ids as corosync generates.

Comment 2 Jason Dillaman 2012-02-17 15:07:38 UTC
Created attachment 563926 [details]
Simple patch to fix the node id assignment for Infiniband

Comment 3 Steven Dake 2012-02-17 15:43:07 UTC
patch looks good.  honzaf please submit upstream.

regards
-steve

Comment 4 Jan Friesse 2012-02-22 09:52:12 UTC
Created attachment 564899 [details]
Patch from upstream git

iba: Use configured node id

Corosync was ignoring nodeid for iba transport and always used
autogenerated one.

Comment 8 Jan Friesse 2012-08-06 10:20:21 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Corosync with IBA transport.

Consequence
Corosync was always using autogenerated NodeID even if there were set one (in config file or by cman)

Fix
Don't ignore nodeid set by user.

Result
Corosync now autogenerated nodeid only when user didn't entered one.

Comment 12 errata-xmlrpc 2013-02-21 07:50:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0497.html


Note You need to log in before you can comment on or make changes to this bug.