Bug 794751 - livecd boot from iscsi storage
Summary: livecd boot from iscsi storage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut
Version: 6.4
Hardware: All
OS: Linux
high
high
Target Milestone: pre-dev-freeze
: ---
Assignee: Harald Hoyer
QA Contact: Release Test Team
URL:
Whiteboard:
: 863964 (view as bug list)
Depends On: 545148
Blocks: 816255 520111 845928 853313 867778
TreeView+ depends on / blocked
 
Reported: 2012-02-17 14:28 UTC by Joey Boggs
Modified: 2016-04-26 14:28 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: dracut could not use the iSCSI and dmsquash-live module together. Consequence: It was not possible to boot from a live medium over iSCSI. Fix: A dracut generated initramfs, which contains the iSCSI and dmsquash-live modules, is now able to boot a live medium via iSCSI. Result: A kernel command line like "root=live:LABEL=<partition-or-iso-label> netroot=iscsi:...." boots the live medium.
Clone Of: 545148
Environment:
Last Closed: 2013-02-21 10:29:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0436 normal SHIPPED_LIVE dracut bug fix and enhancement update 2013-02-20 20:48:34 UTC

Description Joey Boggs 2012-02-17 14:28:56 UTC
+++ This bug was initially created as a clone of Bug #545148 +++

Description of problem:
dracut does not support LiveCD based setups on iSCSI backed storage


Steps to Reproduce:
1. Copy LiveCD contents to iscsi storage
2. Attemt booting from iscsi remote storage

  
Actual results:
- iscsi connection is made, disk is attached, but root  can not be found.

I've tried the exact same setup with the filesystem extracted from the dmsquash and placed on the storage and it boots fine. It just looks like layered boot scenarios of (livecd/iscsi) don't work in this case.

Expected results:
livecd based images booting from remote iscsi

--- Additional comment from fedora-admin-xmlrpc@redhat.com on 2011-10-20 12:19:09 EDT ---

This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

--- Additional comment from apevec@redhat.com on 2011-10-21 06:52:48 EDT ---

(In reply to comment #0)
> 2. Attemt booting from iscsi remote storage

What was the root= parameter you have used?

--- Additional comment from jboggs@redhat.com on 2012-02-15 21:57:14 EST ---

#default saved
set timeout=5
#hiddenmenu
menuentry "oVirt Node Hypervisor 2.2.3-0.1.fc16.gita1053cb" {
set root=(hd0,2)
linux /vmlinuz0 root=LABEL=Root root=iscsi:192.168.122.147::3260::iqn.2006-01.com.openfiler:tsn.ac316c1511c5 ip=eth0:dhcp crashkernel=512M-2G:64M,2G-:128M elevator=deadline quiet rd_NO_LVM rhgb rd.luks=0 rd.md=0 rd.dm=0
initrd /initrd0.img
}


dracut Warning: Can't mount root filesystem
iscsistart: transport class version 2.0-870. iscsid version 2.0-872.15.f16
iscsistart: Logging into iqn.2006-01.com.openfiler:tsn.ac316c1511c5 192.168.122.147:3260,1
iscsistart: version 2.0-872.15.f16
iscsistart: Connection1:0 to [target: iqn.2006-01.com.openfiler:tsn.ac316c1511c5, portal: 192.168.122.147,3260] through [iface: default] is operational now
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy
mount: /dev/sdb already mounted or /sysroot busy


dracut Warning: Can't mount root filesystem

Dropping to debug shell.

sh: can't access tty; job control turned off


------------------------------


changing root line to: root=live:iscsi:192.168.122.147::3260::iqn.2006-01.com.openfiler:tsn.ac316c1511c5 ip=eth0:dhcp


[    0.880906] ioremap error for 0x3ffff000-0x40000000, requested 0x10, got 0x0
Warning: No netboot configured, ignoring ip= lines
[    1.352627] dracut: FATAL: Don't know how to handle 'root=live:iscsi:192.168.122.147::3260::iqn.2006-01.com.openfiler:tsn.ac316c1511c5'
[    1.356854] dracut: Refusing to continue


dracut Warning: Signal caught!
dracut Warning: dracut: FATAL: Don't know how to handle 'root=live:iscsi:192.168.122.147::3260::iqn.2006-01.com.openfiler:tsn.ac316c1511c5'
dracut Warning: dracut: Refusing to continue

[    1.363538] Kernel panic - not syncing: Attempted to kill init!
[    1.365935] Pid: 1, comm: init Not tainted 3.2.6-3.fc16.x86_64 #1
[    1.368104] Call Trace:
[    1.368695]  [<ffffffff815d7120>] panic+0x91/0x1a7
[    1.369832]  [<ffffffff81072541>] do_exit+0x861/0x8a0
[    1.371082]  [<ffffffff810728d2>] do_group_exit+0x42/0xa0
[    1.372562]  [<ffffffff81072947>] sys_exit_group+0x17/0x20
[    1.374067]  [<ffffffff815e9982>] system_call_fastpath+0x16/0x1b

Comment 2 Bhavna Sarathy 2012-02-17 16:35:04 UTC
This dracut bug is blocking ovirt-node that will support booting from iSCSI targets with boot parameters netroot=iscsi:

https://bugzilla.redhat.com/show_bug.cgi?id=520111

Comment 3 Harald Hoyer 2012-02-20 12:57:57 UTC
the kernel command line is wrong:

 root=LABEL=Root
root=iscsi:192.168.122.147::3260::iqn.2006-01.com.openfiler:tsn.ac316c1511c5

it should read:
 root=LABEL=Root
netroot=iscsi:192.168.122.147::3260::iqn.2006-01.com.openfiler:tsn.ac316c1511c5


you cannot specify multiple "root="

Comment 4 Denise Dumas 2012-03-09 18:09:05 UTC
proposing as exception per Bhavna

Comment 9 Mike Burns 2012-04-16 12:50:39 UTC
Response on upstream bug: 

--- Comment #16 from Harald Hoyer <harald@redhat.com> 2012-04-16 05:14:03 EDT ---
Ok, it will not work with the current internal dracut design.
I might get it to work in F18.

Harald -- 

Any chance of this being fixed in 6.3?

Comment 10 Harald Hoyer 2012-04-16 13:06:32 UTC
(In reply to comment #9)
> Response on upstream bug: 
> 
> --- Comment #16 from Harald Hoyer <harald@redhat.com> 2012-04-16 05:14:03 EDT
> ---
> Ok, it will not work with the current internal dracut design.
> I might get it to work in F18.
> 
> Harald -- 
> 
> Any chance of this being fixed in 6.3?

not really

Comment 11 Bhavna Sarathy 2012-04-23 19:20:57 UTC
The RHEV-H iSCSI boot feature has slipped RHEL6.3 due to the Dracut dependency.  At this point both RHEV-H iSCSI boot feature and related Dracut bug is a must fix for RHEL6.4 - both will be proposed and added to RHEL6.4 priority list.
Please plan on fixing the Dracut bug upstream and plan on pulling into RHEL6.4.  In addition, please note that the Dracut bug needs to be fixed well before RHEL6.4 development freeze to allow the RHEV-H engineer to provide the RHEV-H iSCSI boot implementation in 6.4.

Comment 12 Suzanne Yeghiayan 2012-05-18 20:51:54 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 13 RHEL Product and Program Management 2012-07-10 06:03:29 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 14 RHEL Product and Program Management 2012-07-10 23:06:52 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 15 Bhavna Sarathy 2012-09-10 18:10:30 UTC
RHEV-H (In reply to comment #11)
> The RHEV-H iSCSI boot feature has slipped RHEL6.3 due to the Dracut
> dependency.  At this point both RHEV-H iSCSI boot feature and related Dracut
> bug is a must fix for RHEL6.4 - both will be proposed and added to RHEL6.4
> priority list.
> Please plan on fixing the Dracut bug upstream and plan on pulling into
> RHEL6.4.  In addition, please note that the Dracut bug needs to be fixed
> well before RHEL6.4 development freeze to allow the RHEV-H engineer to
> provide the RHEV-H iSCSI boot implementation in 6.4.

pre-dev-freeze set as RHEV-H team needs to do their development and deliver feature well before beta.

Comment 16 Harald Hoyer 2012-09-20 12:51:28 UTC
(In reply to comment #15)
> RHEV-H (In reply to comment #11)
> > The RHEV-H iSCSI boot feature has slipped RHEL6.3 due to the Dracut
> > dependency.  At this point both RHEV-H iSCSI boot feature and related Dracut
> > bug is a must fix for RHEL6.4 - both will be proposed and added to RHEL6.4
> > priority list.
> > Please plan on fixing the Dracut bug upstream and plan on pulling into
> > RHEL6.4.  In addition, please note that the Dracut bug needs to be fixed
> > well before RHEL6.4 development freeze to allow the RHEV-H engineer to
> > provide the RHEV-H iSCSI boot implementation in 6.4.
> 
> pre-dev-freeze set as RHEV-H team needs to do their development and deliver
> feature well before beta.

built dracut-004-287.git20120920.el6 for rhel-6.4-candidate

syntax is "root=live:LABEL=<partition-or-iso-label> netroot=iscsi:...."

works for me with a live iso file provided as an iscsi target

Let me know, if you need something else, or if you need the erratum to be created.

Comment 22 Harald Hoyer 2012-10-19 10:24:04 UTC
*** Bug 863964 has been marked as a duplicate of this bug. ***

Comment 23 Mike Burns 2012-10-19 15:26:29 UTC
Based on discussion from the duplicate bug 863964 - marking this assigned.  booting with root=/rhev-hypervisor.iso does not work anymore.

if [ "${root##live:/dev/}:" != "$root" ]; then
-------------------------^

This ":" causes it to fail.

Comment 24 Phil Knirsch 2012-10-30 13:51:55 UTC
Proposing as an exception as Harald is currently on his honeymoon PTO and we should get this fixed for 6.4 as most of the work has completed and only a very simple typo fix is required to complete this.

Thanks & regards, Phil

Comment 25 Thomas Woerner 2012-11-06 13:35:37 UTC
Setting this bug in modified state. Package dracut-004-302 has been build already and is attached to the errata.

Comment 38 errata-xmlrpc 2013-02-21 10:29:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0436.html


Note You need to log in before you can comment on or make changes to this bug.