Bug 7948 - Exception during/after package load
Exception during/after package load
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-22 11:47 EST by Dan St.Andre'
Modified: 2015-01-07 18:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-22 15:03:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan St.Andre' 1999-12-22 11:47:40 EST
The ERROR Report:
The last entry in the traceback says
File .../todo.py  line 1011  in writeNetworkConfig
f=open(self.instPath + "/etc/sysconfig/network-scripts/ifcfg-" + device,
"w")
IOError [errno 2] no such file or directory:
'/mnt/sysimage/etc/sysconfig/network-scripts/ifcfg-eth0'

Analysis:
Sure enough, the entire folder ../network-scripts/ is missing from the
/mnt/sysimage/etc/sysconfig folder.

This was a CUSTOM install onto two drives of 1024 Mb and 850 Mb.

Discussion:
Since I have limited disk space that is the install target,
my first thought was free space.  However, I used the ALT-F2 shell and
checked "df -k".  I had lots of space on all partitions.

Also, because of the limited disk space, I had "picked" my way through
the features.  On first attempt, I was over size by roughly 30Mb.
I used the [back] buttons and then went through individual package
selection targeting games, desktop art, wallpaper, font collections,
sound files and the like.  I do not recall removing any network related
packages.

On my next attempt, I was warned that I removed QQQ that had dependency
on TTT.  I used [back] again and removed the requesting offender rather
that install the extra package.  Again, I do not recall removing any
network related packages.
Comment 1 Jay Turner 2000-02-22 15:03:59 EST
This issue is resolved in the latest beta installer.
Comment 2 Jay Turner 2000-02-23 07:23:59 EST
Without knowing the packages which you deselected, I would have to say that this
was the result of something "deselecting" the initscripts package, which is the
package that writes the files in the /etc/sysconfig/network-scripts directory.
We have tightened up the base package selection in the latest release so that
those packages get installed under all circumstances and there is no way to
deselect these packages.

Note You need to log in before you can comment on or make changes to this bug.