Bug 79488 - XKeysymDB is included in XFree86.rpm whereas it should be in XFree86-libs.rpm
XKeysymDB is included in XFree86.rpm whereas it should be in XFree86-libs.rpm
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: XFree86 (Show other bugs)
2.1
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://otn.oracle.com/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-12 06:22 EST by VU IT CNS
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-26 01:15:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description VU IT CNS 2002-12-12 06:22:47 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
Oracle's 9.2.0.1i Java-based runInstaller gives a lot of Warnings like: 
 
Warning: translation table syntax error: Unknown keysym name:  osfUp 
Warning: ... found while parsing ':<Key>osfUp:          
SelectionBoxUpOrDown(0)' 
Warning: String to AcceleratorTable conversion encountered errors 
Warning: translation table syntax error: Unknown keysym name:  osfActivate 
Warning: ... found while parsing ':<Key>osfActivate:    
ManagerParentActivate()' 
Warning: String to TranslationTable conversion encountered errors 
 
because the file /usr/X11R6/lib/X11/XKeysymDB is missing. 
It is not necessary for the Oracle installer and server to have XFree86.rpm, 
only XFree86-libs.rpm. From a security point of view, one does not want to 
have unnecessary (and like X potentially dangerous) packages installed on a 
(2.1 Advanced) Server. 
 
All errors mentioned above disappear if XKeysymDB is put in place. 
As this file is in '.../lib/X11', from a logical point of view it should be in 
XFree86-libs.rpm, not XFree86.rpm and would thus enable servers to have a 
minimalist X installation (namely, just the libs). 
Imho the file should be migrated, therefore, from the XFree86 to the 
XFree86-libs package. This will not break installations, because XFree86 has a 
dependency on XFree86-libs. 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. 
2. 
3. 
	 
 
Additional info: 
 
The workaround is simply to install XFree86 (in addition to XFree86-libs), 
secure the file /usr/X11R6/lib/X11/XKeysymDB, then remove the XFree86 package 
again (directory /usr/X11R6/lib/X11, and some other files therein, comes from 
XFree86-libs).
Comment 1 Mike A. Harris 2002-12-12 09:51:21 EST
This enhancement request has already been implemented in XFree86 packaging
in rawhide, and will be present in the next releases of both Red Hat Linux,
as well as Red Hat Linux Advanced Server.  The files are now in a new
subpackage "XFree86-libs-data" in rawhide.

There are a few other similar files that were moved also.

Without promising anything concrete, I will consider this enhancement
request for future X erratum for AS 2.1.  It is probably a fairly safe
change to make, so chances are good I'll make it sometime though.
Comment 2 Mike A. Harris 2002-12-18 14:43:45 EST
I have made this enhancement now also to XFree86 4.1.0-43 package by
moving the files (XErrorDB, XKeysymDB, rgb.txt) from XFree86 to XFree86-libs
subpackage.  I will make a similar change in the XFree86 4.2.1 packaging as
well for consistency.

This will appear in any future erratum at some point, however it is not
released currently, so I'm closing this as RAWHIDE rather than ERRATA for
now.  Rest assured the change will be in the next erratum nonetheless.

Thanks.
Comment 3 Mike A. Harris 2003-05-26 01:15:57 EDT
Reopening to close as ERRATA, as this change is present in the current
errata for AS2.1, and will be in RHL 7.* and 8.0 errata soon as well.

Note You need to log in before you can comment on or make changes to this bug.