Bug 79497 - proxy settings change after applying
Summary: proxy settings change after applying
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gftp   
(Show other bugs)
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: MoveUpstream
Depends On:
Blocks: GnomeUpstream
TreeView+ depends on / blocked
 
Reported: 2002-12-12 13:07 UTC by Need Real Name
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 18:45:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-12-12 13:07:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When I change the FTP - Proxy Server Type and apply the changes, they are not
stored correctly.
The Proxy Server Type always changes to Custom and several commands are appended
to the default commands of the selected Proxy Server Type.

Version-Release number of selected component (if applicable):
2.0.11

How reproducible:
Always

Steps to Reproduce:
1.Start gFTP
2.Menu FTP - Options...
3.Select FTP tab
4.Select any Proxy Server Type (but I need SITE command)
5.Apply & OK
6.Repeat step 2 & 3

Actual Results:  When I change the Proxy Server Type I see the following commands :
USER %pu
PASS %pp
SITE %hh
USER %hu
PASS %hp

This is correct. But when I check these setting after applying the changes, the
Proxy Server Type has changes to Custom and the following commands are shown:
USER %pu
PASS %pp
SITE %hh
USER %hu
PASS %hp
\SER %pu
PASS %pp
SITE %hh
USER %hu
PASS %hp
USER %pu
PASS %pp
SITE %hh
USER %hu
PA

The extra commands are appended on all initially selected Proxy Server Type.

Expected Results:  Settings shouldn't be changes after applying them.

Additional info:

Comment 1 Havoc Pennington 2002-12-13 21:30:30 UTC
Still present in newer releases?

Comment 2 Need Real Name 2002-12-16 10:36:45 UTC
No, the problem isn't present in newer releases.
I have a standard redhat 7.3 box fully updated which I would like to keep
standard redhat.

I compiled gFTP 2.0.14 from the SRPM (from gftp.seul.org) on a redhat 7.3 test
machine and the problem was solved.

Comment 3 Havoc Pennington 2002-12-16 18:21:23 UTC
Changing to MoveUpstream keyword instead of GnomeUpstream tracking bug.
sorry about the spam.

Comment 4 Need Real Name 2002-12-16 19:50:08 UTC
Does this mean gftp 2.0.14 will be included in the updates (rhn) for redhat 7.3
or am I forced to upgrade to redhat 8.0 ?

Comment 5 Havoc Pennington 2002-12-16 21:42:39 UTC
There will not be a gftp errata for 7.3 for this issue, no.
You could just rebuild the 8.0 package on a 7.3 system probably.
If you want to stick to Red Hat packages only, you typically need to 
track new releases fairly closely.

(Note that the Advanced product line has an 
18-24 month release cycle instead of the shorter retail box product 
cycle, and correspondingly has more backported fixes, for customers that 
need more stability. The retail box product is a latest-and-greatest product.)


Note You need to log in before you can comment on or make changes to this bug.