Bug 79501 - Radeon 8500 LE 128 can't do > 1400x1050 in 15, 16, 24
Radeon 8500 LE 128 can't do > 1400x1050 in 15, 16, 24
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-12 09:17 EST by Need Real Name
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-25 21:09:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xfree log (42.22 KB, text/plain)
2002-12-12 09:21 EST, Need Real Name
no flags Details
Config (2.92 KB, text/plain)
2002-12-12 09:22 EST, Need Real Name
no flags Details
XFree86 log file (42.46 KB, text/plain)
2002-12-21 14:46 EST, Need Real Name
no flags Details
Config file update (2.97 KB, text/plain)
2002-12-21 14:47 EST, Need Real Name
no flags Details
Config (3.19 KB, application/octet-stream)
2003-01-25 08:33 EST, Need Real Name
no flags Details
Latest log (39.53 KB, application/octet-stream)
2003-01-25 08:34 EST, Need Real Name
no flags Details
Xdpyinfo (3.90 KB, text/plain)
2003-01-25 08:35 EST, Need Real Name
no flags Details
Config (3.19 KB, text/plain)
2003-01-25 08:38 EST, Need Real Name
no flags Details
Log (39.53 KB, text/plain)
2003-01-25 08:38 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-12-12 09:17:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Can't do higher than 1280x1024 with this built buy ATI Radeon 8500 LE with
128meg DDR. See attached XFree86.0.log + XF86Config

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Either from GUI Display change prog in RH 8,edit XF86Config
2.Change default depth etc - trying 1600x1200x24 or by 15 or 16
3./sbin/telinit 5 after /sbin/telinit 3 or log off and log on

	

Actual Results:  OUT OF RANGE

Expected Results:  ViewSonic A90 performs with 1600x1200 with Radeon 7500 64 meg
built by ATI... Should do 1600x1200

Additional info:
Comment 1 Need Real Name 2002-12-12 09:21:42 EST
Created attachment 88584 [details]
Xfree log
Comment 2 Need Real Name 2002-12-12 09:22:33 EST
Created attachment 88585 [details]
Config
Comment 3 Mike A. Harris 2002-12-17 14:28:13 EST
Recommended to also submit bug report to xpert@xfree86.org and/or dri-devel
also, so more developers are aware of the issue.  I don't have an 8500LE
to test with, just an 8500.  I'll test it soon on the 8500 though.
Comment 4 Need Real Name 2002-12-17 23:37:05 EST
Submitted to xpert@xfree.org as suggested by fearlous leader :)
Comment 5 Need Real Name 2002-12-20 08:33:14 EST
After further testing I'm now stating that this Radeon 8500 LE 128 can't do >
1400x1050 in 15, 16, 24
Comment 6 Mike A. Harris 2002-12-21 13:17:29 EST
Hmm, your above config file is set to 1280, not 1400..  
Can you attach a config and log from trying it with 1400?  That's what
I wanted to see, was your failing config and log.. the one attached isn't
for that.
Comment 7 Mike A. Harris 2002-12-21 13:23:03 EST
(II) RADEON(0): Not using default mode "1600x1200" (width too large for virtual
size)
(II) RADEON(0): Not using default mode "1600x1200" (width too large for virtual
size)
(II) RADEON(0): Not using default mode "1400x1050" (width too large for virtual
size)
(II) RADEON(0): Not using default mode "1400x1050" (width too large for virtual
size)
(II) RADEON(0): Not using default mode "1400x1050" (width too large for virtual
size)
(--) RADEON(0): Virtual size is 1280x1024 (pitch 1280)


You've set the virtual size to 1280x1024, so any mode larger than that is too
big.  Again, the config file and log file attached do not match an X session
that you're describing as problematic.
Comment 8 Need Real Name 2002-12-21 14:46:27 EST
Created attachment 88845 [details]
XFree86 log file
Comment 9 Need Real Name 2002-12-21 14:47:20 EST
Created attachment 88846 [details]
Config file update
Comment 10 Mike A. Harris 2002-12-21 15:45:12 EST
This isn't relevant to the problem, but I noticed you are forcing
video memory size in your config with:   VideoRam    131072

That line isn't needed (or should not be needed).

Again, thats not related to the problem at hand though, just thought
I would mention it.
Comment 11 Mike A. Harris 2002-12-21 15:46:47 EST
The log file is showing the modes you have set in your config file, and shows
1400x1050 is set as the virtual size below.  The first mode listed should
end up also being the native default starting resolution too:

(--) RADEON(0): Virtual size is 1400x1050 (pitch 1408)
(**) RADEON(0): *Default mode "1400x1050": 155.8 MHz, 81.5 kHz, 74.8 Hz
(II) RADEON(0): Modeline "1400x1050"  155.80  1400 1464 1784 1912  1050 1052
1064 1090 +hsync +vsync
(**) RADEON(0): *Default mode "1280x1024": 135.0 MHz, 80.0 kHz, 75.0 Hz
(II) RADEON(0): Modeline "1280x1024"  135.00  1280 1296 1440 1688  1024 1025
1028 1066 +hsync +vsync
(**) RADEON(0): *Default mode "1280x960": 148.5 MHz, 85.9 kHz, 85.0 Hz
(II) RADEON(0): Modeline "1280x960"  148.50  1280 1344 1504 1728  960 961 964
1011 +hsync +vsync
(**) RADEON(0): *Default mode "1152x864": 121.5 MHz, 77.5 kHz, 85.1 Hz
(II) RADEON(0): Modeline "1152x864"  121.50  1152 1216 1344 1568  864 865 868
911 +hsync -vsync
(**) RADEON(0): *Default mode "1024x768": 94.5 MHz, 68.7 kHz, 85.0 Hz
(II) RADEON(0): Modeline "1024x768"   94.50  1024 1072 1168 1376  768 769 772
808 +hsync +vsync
(**) RADEON(0): *Default mode "800x600": 56.3 MHz, 53.7 kHz, 85.1 Hz
(II) RADEON(0): Modeline "800x600"   56.30  800 832 896 1048  600 601 604 631
+hsync +vsync
(**) RADEON(0): *Default mode "640x480": 74.2 MHz, 85.9 kHz, 85.1 Hz (D)
(II) RADEON(0): Modeline "640x480"   74.25  640 672 752 864  480 480 482 505
doublescan +hsync +vsync

Comment 12 Mike A. Harris 2002-12-21 15:52:06 EST
While running with this configuration, can you please run:

xdpyinfo > xdpyinfo.log

And also attach that file please.

Also, what is it that you are doing to confirm the resolution that is running
on your display?  I'm just curious because the bottom of your log file also
shows 1400x1050 resolution being set via the following modeline:

GetModeLine - scrn: 0 clock: 155800
GetModeLine - hdsp: 1400 hbeg: 1464 hend: 1784 httl: 1912
              vdsp: 1050 vbeg: 1052 vend: 1064 vttl: 1090 flags: 5


With this config file, your system should be running in 1400x1050.  However
looking at the initial bug report comments again:

>Steps to Reproduce:
>1.Either from GUI Display change prog in RH 8,edit XF86Config
>2.Change default depth etc - trying 1600x1200x24 or by 15 or 16
>3./sbin/telinit 5 after /sbin/telinit 3 or log off and log on

You're stating you can't do 1600x1200 here, but your config file is not
configured to do 1600x1200.

Please run redhat-config-xfree86 --reconfig, and choose 1600x1200 resolution,
then save it, and restart X.  It should just work IMHO.  If not, attach
the new log and config file, and xdpyinfo output.


Comment 13 Need Real Name 2003-01-25 08:31:30 EST
As per advice I ran redhat-config-xfree86 --reconfig, chose 1600x1200
resolution, save it and restarted X
Same thing "OUT OF RANGE"

See attached XFree86.0.log, XFree86 config and xdpyinfo
Comment 14 Need Real Name 2003-01-25 08:33:52 EST
Created attachment 89596 [details]
Config
Comment 15 Need Real Name 2003-01-25 08:34:33 EST
Created attachment 89597 [details]
Latest log
Comment 16 Need Real Name 2003-01-25 08:35:09 EST
Created attachment 89598 [details]
Xdpyinfo
Comment 17 Need Real Name 2003-01-25 08:38:10 EST
Created attachment 89599 [details]
Config
Comment 18 Need Real Name 2003-01-25 08:39:01 EST
Created attachment 89600 [details]
Log
Comment 19 Need Real Name 2003-01-25 21:09:18 EST
Apparently DRI bug as per some hint made once by someone. Or perhaps the card
can't handle it.
Either way I have no more time to spend on this. Dri-Devel doesn't respond on
the bug either.

Apparently then it's not a bug to those in the know... Just a buggy radeon 8500 LE

Note You need to log in before you can comment on or make changes to this bug.