Bug 795100 - SELinux is preventing /lib/systemd/systemd-logind (deleted) from 'setattr' accesses on the None sr0.
SELinux is preventing /lib/systemd/systemd-logind (deleted) from 'setattr' ac...
Status: CLOSED DUPLICATE of bug 755535
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Denemark
Fedora Extras Quality Assurance
abrt_hash:633aac7e4317ac95665fd107b12...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-19 06:21 EST by Grosswiler Roger
Modified: 2012-06-07 16:36 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 16:36:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Grosswiler Roger 2012-02-19 06:21:15 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.6-3.fc16.x86_64
reason:         SELinux is preventing /lib/systemd/systemd-logind (deleted) from 'setattr' accesses on the None sr0.
time:           Son 19 Feb 2012 12:21:03 CET

description:
:SELinux is preventing /lib/systemd/systemd-logind (deleted) from 'setattr' accesses on the None sr0.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemd-logind (deleted) should be allowed setattr access on the sr0 <Unbekannt> by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemd-logind /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:systemd_logind_t:s0
:Target Context                system_u:object_r:virt_content_t:s0
:Target Objects                sr0 [ None ]
:Source                        systemd-logind
:Source Path                   /lib/systemd/systemd-logind (deleted)
:Port                          <Unbekannt>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.6-3.fc16.x86_64 #1 SMP Mon Feb
:                              13 20:35:42 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Son 19 Feb 2012 10:27:56 CET
:Last Seen                     Son 19 Feb 2012 12:19:39 CET
:Local ID                      d010e50a-e796-475c-90df-cbff526520f0
:
:Raw Audit Messages
:type=AVC msg=audit(1329650379.736:884): avc:  denied  { setattr } for  pid=1049 comm="systemd-logind" name="sr0" dev=devtmpfs ino=7220 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:virt_content_t:s0 tclass=blk_filenode=(removed) type=SYSCALL msg=audit(1329650379.736:884): arch=c000003e syscall=188 success=yes exit=0 a0=89ba40 a1=3913e05d2b a2=89b990 a3=2c items=0 ppid=1 pid=1049 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="systemd-logind" exe=2F6C69622F73797374656D642F73797374656D642D6C6F67696E64202864656C6574656429 subj=system_u:system_r:systemd_logind_t:s0 key=(null)
:
:
:Hash: systemd-logind,systemd_logind_t,virt_content_t,None,setattr
:
:audit2allow
:
:
:audit2allow -R
:
:
Comment 1 Daniel Walsh 2012-02-20 14:20:37 EST
This looks like this might be a crash between libvirt handling of /dev/sr0 and systemd.
Comment 2 Daniel Walsh 2012-02-20 14:21:29 EST
Dan Berrange, shouldn't libvirt relabel /dev/sr0 to removable_device_t when it is done with it?
Comment 3 Lennart Poettering 2012-03-15 15:57:25 EDT
as CD drives are marked for "uaccess" systemd-logind will give the currently logged in user on the seat access to it via ACL and as soon as the session is swicthed will update the ACL.
Comment 4 Cole Robinson 2012-06-07 16:36:17 EDT

*** This bug has been marked as a duplicate of bug 755535 ***

Note You need to log in before you can comment on or make changes to this bug.