This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 795182 - [abrt] kernel: WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/iwlwifi/iwl-trans-pcie-tx.c:670 iwl_enqueue_hcmd+0x5c8/0x5f0 [iwlwifi]()
[abrt] kernel: WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wirel...
Status: CLOSED DUPLICATE of bug 770484
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
abrt_hash:eee09591a20051efbad3c61f4ce...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-19 18:15 EST by eric@christensenplace.us
Modified: 2012-03-26 10:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 10:55:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description eric@christensenplace.us 2012-02-19 18:15:00 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.6-3.fc16.x86_64 root=/dev/mapper/vg_ericlaptop-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_ericlaptop/lv_swap KEYTABLE=us quiet rd.luks.uuid=luks-262e7b6b-dd14-436c-9b00-afecd7c07990 rhgb rd.lvm.lv=vg_ericlaptop/lv_root SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8
kernel:         3.2.6-3.fc16.x86_64
reason:         WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/iwlwifi/iwl-trans-pcie-tx.c:670 iwl_enqueue_hcmd+0x5c8/0x5f0 [iwlwifi]()
time:           Sun 19 Feb 2012 06:10:26 PM EST

backtrace:
:WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/iwlwifi/iwl-trans-pcie-tx.c:670 iwl_enqueue_hcmd+0x5c8/0x5f0 [iwlwifi]()
:Hardware name: 4270CTO
:Modules linked in: rndis_wlan rndis_host cdc_ether usbnet mii usb_storage tcp_lp vfat fat mmc_block ppdev parport_pc lp parport fuse lockd rfcomm bnep ipt_LOG nf_conntrack_ipv4 nf_defrag_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables binfmt_misc snd_hda_codec_conexant uvcvideo videodev media v4l2_compat_ioctl32 snd_hda_intel snd_hda_codec snd_hwdep snd_seq arc4 btusb bluetooth snd_seq_device joydev snd_pcm microcode i2c_i801 iTCO_wdt iTCO_vendor_support e1000e thinkpad_acpi iwlwifi snd_timer tpm_tis mac80211 cfg80211 snd_page_alloc rfkill snd soundcore tpm tpm_bios uinput sunrpc xts gf128mul dm_crypt firewire_ohci sdhci_pci sdhci firewire_core mmc_core crc_itu_t i915 nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video [last unloaded: scsi_wait_scan]
:Pid: 18748, comm: kworker/u:0 Tainted: G        W    3.2.6-3.fc16.x86_64 #1
:Call Trace:
: [<ffffffff8106dd4f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106ddaa>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa03596f8>] iwl_enqueue_hcmd+0x5c8/0x5f0 [iwlwifi]
: [<ffffffff8138f923>] ? dev_err+0x53/0x60
: [<ffffffff812b6386>] ? cpumask_next_and+0x36/0x50
: [<ffffffff8105014c>] ? copy_siginfo_from_user32+0x4c/0x80
: [<ffffffffa035a1f0>] iwl_trans_pcie_send_cmd+0x70/0x3c0 [iwlwifi]
: [<ffffffffa035340b>] iwl6000_hw_channel_switch+0x12b/0x1a0 [iwlwifi]
: [<ffffffff810653be>] ? try_to_wake_up+0x22e/0x290
: [<ffffffff81065455>] ? wake_up_process+0x15/0x20
: [<ffffffff81087b54>] ? wake_up_worker+0x24/0x30
: [<ffffffff81088640>] ? insert_work+0x70/0x80
: [<ffffffff81088730>] ? __queue_work+0xe0/0x3e0
: [<ffffffffa0289663>] ? cfg80211_inform_bss_frame+0x93/0x220 [cfg80211]
: [<ffffffff81163c7b>] ? kfree+0x3b/0x140
: [<ffffffffa02885e0>] ? is_mesh_bss+0x80/0x80 [cfg80211]
: [<ffffffffa028861c>] ? bss_release+0x3c/0x70 [cfg80211]
: [<ffffffffa033faee>] iwlagn_mac_channel_switch+0x1ae/0x1f0 [iwlwifi]
: [<ffffffffa02cde16>] ieee80211_sta_process_chanswitch+0x116/0x240 [mac80211]
: [<ffffffffa02ce32d>] ieee80211_rx_bss_info+0x13d/0x1a0 [mac80211]
: [<ffffffffa02e6c62>] ? ieee802_11_parse_elems_crc+0x472/0x4c0 [mac80211]
: [<ffffffffa02ced2b>] ieee80211_rx_mgmt_beacon+0x3fb/0x7f0 [mac80211]
: [<ffffffffa02d06e3>] ieee80211_sta_rx_queued_mgmt+0x2b3/0x3f0 [mac80211]
: [<ffffffffa02d3ffb>] ieee80211_iface_work+0x25b/0x350 [mac80211]
: [<ffffffffa02d3da0>] ? ieee80211_teardown_sdata+0xe0/0xe0 [mac80211]
: [<ffffffffa02d3da0>] ? ieee80211_teardown_sdata+0xe0/0xe0 [mac80211]
: [<ffffffff81089ddd>] process_one_work+0x11d/0x470
: [<ffffffff8108b1df>] worker_thread+0x15f/0x350
: [<ffffffff8108b080>] ? manage_workers+0x230/0x230
: [<ffffffff8108fb9c>] kthread+0x8c/0xa0
: [<ffffffff815ebaf4>] kernel_thread_helper+0x4/0x10
: [<ffffffff8108fb10>] ? kthread_worker_fn+0x190/0x190
: [<ffffffff815ebaf0>] ? gs_change+0x13/0x13

smolt_data:
:
:
:General
:=================================
:UUID: be945694-df8f-48cc-990c-1ab7dbfb9473
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4386.73
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 2201
:System Memory: 7870
:System Swap: 9919
:Vendor: LENOVO
:System: 4270CTO ThinkPad W520
:Form factor: Notebook
:Kernel: 3.2.6-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4480:59442:6058:8655) pci, firewire_ohci, FIREWIRE, FireWire Host Controller
:(4480:59427:6058:8655) pci, sdhci-pci, BASE, N/A
:(32902:260:6058:8655) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:257:6058:8655) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:(4147:404:6058:8655) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:7202:6058:8655) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7171:6058:8655) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7247:6058:8655) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(32902:5378:6058:8654) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7213:6058:8655) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:8655) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:7226:6058:8655) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:133:32902:4881) pci, iwlwifi, NETWORK, Centrino Advanced-N 6205 AGN
:(32902:294:6058:8657) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7196:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7192:6058:8655) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:6058:8655) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7229:6058:8655) pci, serial, 16550_SERIAL, 6 Series/C200 Series Chipset Family KT Controller
:(4318:3578:6058:8657) pci, nouveau, VIDEO, GF108 [Quadro 1000M]
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_ericlaptop-lv_root / ext4 4096 4096 13081819 9769930 9114570 3276800 2931383 2931383
:/dev/sda1 /boot ext4 1024 1024 508745 411069 385469 128016 127785 127785
:/dev/mapper/vg_ericlaptop-lv_home /home ext4 4096 4096 15455094 1508012 733868 3874816 3560155 3560155
:
Comment 1 John W. Linville 2012-02-20 10:06:26 EST
The kernel in question is using compat-wireless-3.3-rc1-2 with the following patches applied:

Patch50101: mac80211-fix-debugfs-key-station-symlink.patch
Patch50102: brcmsmac-fix-tx-queue-flush-infinite-loop.patch
Patch50103: mac80211-Use-the-right-headroom-size-for-mesh-mgmt-f.patch
Patch50105: b43-add-option-to-avoid-duplicating-device-support-w.patch
Patch50106: mac80211-update-oper_channel-on-ibss-join.patch
Patch50107: mac80211-set-bss_conf.idle-when-vif-is-connected.patch
Patch50108: iwlwifi-fix-PCI-E-transport-inta-race.patch
Patch50109: bcma-Fix-mem-leak-in-bcma_bus_scan.patch
Patch50110: rt2800lib-fix-wrong-128dBm-when-signal-is-stronger-t.patch
Patch50111: iwlwifi-make-Tx-aggregation-enabled-on-ra-be-at-DEBU.patch
Patch50112: ssb-fix-cardbus-slot-in-hostmode.patch
Patch50113: iwlwifi-don-t-mess-up-QoS-counters-with-non-QoS-fram.patch
Patch50114: mac80211-timeout-a-single-frame-in-the-rx-reorder-bu.patch
Patch50115: ath9k-use-WARN_ON_ONCE-in-ath_rc_get_highest_rix.patch
Patch50116: mwifiex-handle-association-failure-case-correctly.patch
Patch50117: ath9k-Fix-kernel-panic-during-driver-initilization.patch
Patch50118: mwifiex-add-NULL-checks-in-driver-unload-path.patch
Patch50119: ath9k-fix-a-WEP-crypto-related-regression.patch
Patch50120: ath9k_hw-fix-a-RTS-CTS-timeout-regression.patch
Patch50121: bcma-don-t-fail-for-bad-SPROM-CRC.patch
Patch50122: zd1211rw-firmware-needs-duration_id-set-to-zero-for-.patch
Patch50123: mac80211-Fix-a-rwlock-bad-magic-bug.patch
Patch50124: rtlwifi-Modify-rtl_pci_init-to-return-0-on-success.patch

The warning indicates we are here in iwl-trans-pcie-tx.c:

        /*
         * If any of the command structures end up being larger than
         * the TFD_MAX_PAYLOAD_SIZE and they aren't dynamically
         * allocated into separate TFDs, then we will need to
         * increase the size of the buffers.
         */
        if (WARN_ON(copy_size > TFD_MAX_PAYLOAD_SIZE))
                return -EINVAL;
Comment 2 Dave Jones 2012-03-22 12:56:18 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 13:00:09 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:11:25 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Dave Jones 2012-03-26 10:55:16 EDT

*** This bug has been marked as a duplicate of bug 770484 ***

Note You need to log in before you can comment on or make changes to this bug.