Bug 795289 - trusted.glusterfs.pathinfo returns I/O error for a dht volume
trusted.glusterfs.pathinfo returns I/O error for a dht volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: shishir gowda
amainkar
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-02-20 01:43 EST by Venky Shankar
Modified: 2015-04-20 07:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:20:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0beta
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Venky Shankar 2012-02-20 01:43:45 EST
On a DHT* volume getting extended attribute for a file return I/O error.

The problem is in getting the hashed_subvol in dht_getxattr() due to loc->name being NULL. The side effect of this is call_cnt getting initialized to an incorrect value resulting in the following log messages from cbk and a failed fop call.

Log messgages (client):

[2012-02-20 11:39:50.913102] E [dht-common.c:1730:dht_vgetxattr_cbk] 0-this->name: Unable to find hashed_subvol for path (<REPLICATE:colon-dr-replicate-1> <POSIX:h3ckers-pride:/d1r0/f0> <POSIX:h3ckers-pride:/d1r1/f0>) Link:
Comment 1 Anand Avati 2012-04-19 02:42:39 EDT
CHANGE: http://review.gluster.com/3175 (cluster/dht: Remove un-used pathinfo code for link files) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.