Bug 79534 - xemacs do not grok OE/oe symbols
xemacs do not grok OE/oe symbols
Status: CLOSED UPSTREAM
Product: Red Hat Raw Hide
Classification: Retired
Component: xemacs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-12 15:18 EST by Nicolas Mailhot
Modified: 2015-01-07 19:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 20:23:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2002-12-12 15:18:59 EST
Among the small changes from iso8859-15 to iso8859-1 is the introduction of the
OE/oe character.

It is important in French, and seems to have been forgotten in iso8859-1 only
because people used to dumb typewriters typed o then e instead (note this is not
the case of any serious publishing operation).

Unfortunately, xemacs seems not to be aware of the change. When I press the
correct keyboard key it complains "OE not defined" (I know my system is
correctly configured since it works like a charm in gedit for example).

So it seems it only needs to be referenced in whatever table xemacs uses ; a
very small change for a very big gain (for french users, at least)
Comment 1 Jens Petersen 2002-12-17 03:26:26 EST
[Btw latin-euro-input has a quail input method that may help/annoy you
until this is fixed...

M-x load-library latin-euro-input RET C-x RET C-\ latin-9-prefix RET
]

Unfortunately I don't have a French keyboard.  Could you tell me what
X keysym the OE key generates?  Unless you know the answer offhand,
you should be able to see it in the output of "xev" when you press and
release the key.

It should be too hard to port quail french-keyboard input method to
Latin-9 (=iso8859-15), but of course it should be supported natively.
Need to check if this has already been done in cvs.
Comment 2 Nicolas Mailhot 2002-12-17 03:48:50 EST
It's OE/oe (I have an updated fr X map I'm preparing for XFree86 inclusion at
http://mapage.noos.fr/nmailhot/fr-latin9-pc)

Since then I think I found xemacs also do not like leftdoublequotemark,
rightdoublequotemark (must check if these are in latin9, however they are in
XFRee86 default "latin" keyboard core) and ISO_Level3_Shift (cut and pasted from
the current fr XFRee86 layout)

I use all those in my keymap, *but* they are all taken from existing XFree86 maps
Comment 3 Jens Petersen 2002-12-18 06:54:04 EST
Waiting on latin-unity maintainer to add bindings to latin-unity
like the one for euro.
Comment 4 Nicolas Mailhot 2003-02-26 16:31:34 EST
Just a checkpoint to confirm it's still in
xemacs-21.4.12-6

(and my X keymap made it in XFree86 proper btw)

Note You need to log in before you can comment on or make changes to this bug.