Bug 795412 - No poweroff/reboot/sound volume option in greeter without ConsoleKit installed
No poweroff/reboot/sound volume option in greeter without ConsoleKit installed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
17
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-02-20 07:45 EST by Kamil Páral
Modified: 2012-04-05 22:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 22:29:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-02-20 07:45:47 EST
Description of problem:
I installed F17 Alpha RC2+updates inside KVM. After boot there is no poweroff/reboot option in GDM. I have to log in in order to power off the machine.

This is a regression from F16.

Version-Release number of selected component (if applicable):
gdm-3.2.1.1-14.fc17
gnome-shell-3.3.5-2.fc17

How reproducible:
always
Comment 1 Kamil Páral 2012-02-20 07:46:23 EST
I'll check whether this manifests also on bare metal.
Comment 2 Kamil Páral 2012-02-20 07:51:09 EST
Since I suppose the option for poweroff/reboot should be there, I'm proposing this as a Beta blocker:

All release-blocking desktops' offered mechanisms (if any) for shutting down, logging out and rebooting must work
https://fedoraproject.org/wiki/Fedora_17_Beta_Release_Criteria
Comment 3 Kamil Páral 2012-02-21 11:10:47 EST
On bare metal there is just 'suspend' menu item, no poweroff/reboot either.
Comment 4 Adam Williamson 2012-03-02 12:43:27 EST
Discussed at 2011-03-02 blocker review meeting. Agreed this is not a blocker: the criterion requires that the options *that are present* must work, it doesn't require any particular options to be present or not present.

We are a bit worried about this bug, though, because 'do it via GDM' is the 'official' GNOME answer to 'how do I reboot / shutdown?' With shutdown / reboot in GDM broken, the only way you can possibly shutdown/reboot graphically from GNOME is the un-discoverable alt key workaround. So we may accept this as a final blocker if it's not fixed by then.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Kamil Páral 2012-03-02 13:22:24 EST
Re-proposing as F17 Final Blocker.

Ray, can you please confirm that this is a bug and it is not an intended behavior?
Comment 6 Kamil Páral 2012-03-03 10:48:34 EST
I have found the problem. If I install ConsoleKit, volume control and power control (reboot, poweroff) icons appear in GDM.

But, because ConsoleKit should be removed from the default installation [1], we can't just add it back, can we?

GDM has to be patched to work without ConsoleKit properly.


[1] http://fedoraproject.org/wiki/Features/ckremoval
Comment 7 Adam Williamson 2012-03-05 17:33:07 EST
yup, indeed, if ConsoleKit removal is the cause here the fix is to make gdm work correctly without CK, not reinstate CK.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Matthias Clasen 2012-03-07 16:03:11 EST
This is waiting for an accountsservice patch from Lennart; should arrive next week
Comment 9 Adam Williamson 2012-03-09 22:03:51 EST
It would be good if you guys could try and ensure this shows up in good time for Beta.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Matthias Clasen 2012-03-27 20:18:25 EDT
Should be fixed with accountsservice 0.6.17 and gdm 3.4.0.1 - we'll get those out as updates soon.

Note You need to log in before you can comment on or make changes to this bug.