Bug 795460 - postgresql fails to build on multi-core due to blocking error
postgresql fails to build on multi-core due to blocking error
Status: CLOSED DUPLICATE of bug 795553
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
rawhide
arm Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-02-20 10:43 EST by Mark Langsdorf
Modified: 2012-04-03 11:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 795553 (view as bug list)
Environment:
Last Closed: 2012-04-03 11:22:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Langsdorf 2012-02-20 10:43:13 EST
Description of problem:
postgresql builds on armhfp but fails to complete the regression tests if the builder has multiple cores. 

Version-Release number of selected component (if applicable):
postgresql-9.1.2 on armhfp

How reproducible:
run mock on an SMP capable ARM system and rebuild the postgresql-9.1.2 srpm.

Actual results:
Failure

Expected results:
Successfully built RPM

Additional info:
the issue is resolved by http://git.postgresql.org/gitweb/?p=postgresql.git&a=commitdiff&h=bb65cb8cdf864e61bc939d3c4b28bbd43d926700

Please add to the rawhide postgresql. Thanks.
Comment 1 Brendan Conoboy 2012-02-20 15:54:50 EST
Please also put the patch in the F17 branch as we'll need it in both places.
Comment 2 Tom Lane 2012-04-03 11:22:36 EDT

*** This bug has been marked as a duplicate of bug 795553 ***

Note You need to log in before you can comment on or make changes to this bug.