Bug 795597 - mvn zanata:pull writes ? for Unicode characters (project-type: properties)
mvn zanata:pull writes ? for Unicode characters (project-type: properties)
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
1.4.5
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Sean Flanigan
Carlos Munoz
: Regression
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2012-02-20 19:55 EST by Sean Flanigan
Modified: 2013-07-10 02:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.4.5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:08:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2012-02-20 19:55:55 EST
Description of problem:

mvn zanata:pull is creating .properties files with ? for Unicode characters, instead of encoding them with \uxxxx.

Version-Release number of selected component (if applicable):
1.4.5

How reproducible:
100%
Comment 2 Carlos Munoz 2012-02-21 17:50:29 EST
Verified with Zanata version 1.5.0-alpha-2-SNAPSHOT (20120221-1802)
and Zanata version 1.4.5-SNAPSHOT (20120123-1407).
Comment 3 Carlos Munoz 2012-02-21 18:16:12 EST
Verified with Zanata client versions 1.5.0-alpha-2-SNAPSHOT (20120221-1802) and
1.4.5.1

Note You need to log in before you can comment on or make changes to this bug.