Bug 79561 - heavy load = Segmentation fault
heavy load = Segmentation fault
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.3
i586 Linux
high Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-13 06:55 EST by Jacob Friis Larsen
Modified: 2007-03-26 23:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 11:45:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Friis Larsen 2002-12-13 06:55:54 EST
Description of problem:
During heavy load I get:
[Fri Dec 13 12:32:42 2002] [notice] child pid 16686 exit signal Segmentation 
fault (11)


Version-Release number of selected component (if applicable):
php-4.1.2-7.3.6


How reproducible:


Steps to Reproduce:
1. compile apache with php as a built-in module.
2. Stress test with heavy load
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Joe Orton 2002-12-13 08:20:15 EST
Need more information than that; are any other Apache modules in use; is it a
particular script which causes segfaults? What modules if any does your script use? 
Comment 2 Jacob Friis Larsen 2002-12-13 08:54:15 EST
> Need more information than that;
Can this help you:
http://bugs.php.net/bug.php?id=20985

> are any other Apache modules in use;
Modules:
mod_php4, mod_setenvif, mod_auth, mod_access, mod_rewrite, mod_alias, 
mod_actions, mod_asis, mod_dir, mod_autoindex, mod_negotiation, mod_mime, 
mod_log_config, http_core

> is it a particular script which causes segfaults?
I don't know. How can I find out?
> What modules if any does your script use?
I know I use mod_php4 and mod_rewrite
Comment 3 Jacob Friis Larsen 2002-12-13 10:46:48 EST
I have now tested with RPMs from Redhat:
apache-1.3.27-2.i386.rpm
php-4.1.2-7.3.6.i386.rpm
php-mysql-4.1.2-7.3.6.i386.rpm

And these from MySQL:
MySQL-shared-3.23.54-1.i386.rpm
MySQL-4.0.5-0.i386.rpm

And i get the same error:
[Fri Dec 13 16:45:25 2002] [notice] child pid 1273 exit signal Segmentation 
fault (11)
... and several of those.
Comment 4 Joe Orton 2005-01-25 11:45:36 EST
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

c) report the bug to the Fedora Legacy project who may wish to
continue maintenance of this package.

Note You need to log in before you can comment on or make changes to this bug.