This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 795615 - Webtran failed to stay at current page if previous page contains large chunk of text translation.
Webtran failed to stay at current page if previous page contains large chunk ...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Scripts (Show other bugs)
1.5
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2012-02-20 23:08 EST by Ding-Yi Chen
Modified: 2012-03-06 19:08 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.5.0-alpha-2-SNAPSHOT (20120223-1307)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:08:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-02-20 23:08:07 EST
Description of problem:
If we fill the page 1 with large translation, clicking on last entries in page 2 won't open the editor, instead, it keep fall back to page 1.

Version-Release number of selected component (if applicable):
Zanata version 1.5-SNAPSHOT (20120216-2319)

How reproducible:
Always

Steps to Reproduce:
1. Copy a large chunk of text, say Ctrl-A and Ctrl-C on https://community.jboss.org/wiki/Zanata?_sscc=t
2. Open a document that has multiple pages, such as Fedora Security Guide-> document Firewall
3. Paste the large chunk of text to 4th last entry
4. Paste the large chunk of text to 3rd last entry
5. Paste the large chunk of text to 2nd last entry
6. Paste the large chunk of text to last entry
7. Click on next page, you should be at page 2
8. Click at 2nd last entry
  
Actual results:
Page change to page 1

Expected results:
Page stay at page 2, and editor open on 2nd last entry.

Additional info:
It looks like it's easier to trigger this bug by working on the bottom part of page.
Comment 3 Ding-Yi Chen 2012-02-22 22:39:31 EST
VERIFIED with Zanata version 1.5.0-alpha-2-SNAPSHOT (20120223-1307)

Note You need to log in before you can comment on or make changes to this bug.