This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 795792 - date is set to 1.1.1970
date is set to 1.1.1970
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-02-21 09:41 EST by Kamil Páral
Modified: 2012-04-12 07:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 07:53:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-02-21 09:41:03 EST
Description of problem:
When I use gnome Control Center -> Date and Time to set system time, no matter what time I set, it gets reset to 1.1.1970 UTC (the local time is plus or minus a few hours, depending on your timezone).

I have seen the same issue both in KVM machine and on bare-metal machine.

Version-Release number of selected component (if applicable):
control-center-3.3.5-1.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. run control center -> date and time
2. move time, e.g. add a day, subtract an hour, or similar
3. look into the panel or issue "date" in terminal. you'll see 1.1.1970 UTC
  
Additional info:
My colleague tested that he has no problems with control-center-3.3.5-1.fc17.x86_64. Maybe it is a problem only for i686?
Comment 1 Matthias Clasen 2012-03-11 19:48:48 EDT
Hmm, not happening here either, on x86_64 - do you still see this problem ?
Comment 2 Kamil Páral 2012-03-12 05:33:27 EDT
Yes I still see it. It seems to be broken just on i686.

control-center-3.3.91-1.fc17.i686
Comment 3 Bastien Nocera 2012-03-12 11:27:26 EDT
Can you run:
dbus-monitor --system
and reproduce the bug?
Comment 4 Bastien Nocera 2012-03-12 11:42:40 EDT
Never mind.

This should be fixed by:
http://git.gnome.org/browse/gnome-control-center/commit/?id=bd41bd788be0f999e95ddb9a7b1ea8f507733646

commit bd41bd788be0f999e95ddb9a7b1ea8f507733646
Author: Bastien Nocera <hadess@hadess.net>
Date:   Mon Mar 12 16:37:53 2012 +0100

    datetime: Fix broken time setting on 32-bit machines
    
    time_t might be a 32-bit integer, which wouldn't be big enough
    to contain the number of microseconds since Epoch (since it can
    only fit the number of seconds from Epoch until 2038).
    
    https://bugzilla.redhat.com/show_bug.cgi?id=795792
Comment 5 Kamil Páral 2012-03-12 12:28:59 EDT
Great job, thanks. I'm reopening this bug since we need it to track the Fedora blocker status. Please push the fix to Fedora Updates, thanks.
Comment 6 Matthias Clasen 2012-03-24 19:38:28 EDT
Fix is included in the .92 build
Comment 7 Kamil Páral 2012-03-26 08:05:44 EDT
The build is here:

https://admin.fedoraproject.org/updates/FEDORA-2012-4478/anjuta-3.3.92-1.fc17,atk-2.3.95-1.fc17,at-spi2-atk-2.3.92-1.fc17,at-spi2-core-2.3.92-1.fc17,baobab-3.3.4-1.fc17,brasero-3.3.92-1.fc17,clutter-1.9.16-1.fc17,cogl-1.10.0-1.fc17,dconf-0.11.7-1.fc17,eog-3.3.92-1.fc17,eog-plugins-3.3.92-1.fc17,epiphany-3.3.92-1.fc17,evince-3.3.92-1.fc17,file-roller-3.3.92-1.fc17,gcr-3.3.92-2.fc17,gdk-pixbuf2-2.26.0-1.fc17,gedit-3.3.8-1.fc17,gjs-1.31.22-1.fc17,glib2-2.31.22-1.fc17,glib-networking-2.31.22-1.fc17,gnome-backgrounds-3.3.92-1.fc17,gnome-bluetooth-3.3.92-1.fc17,gnome-contacts-3.3.92-1.fc17,control-center-3.3.92-1.fc17,gnome-desktop3-3.3.92-1.fc17,gnome-devel-docs-3.3.92-1.fc17,gnome-documents-0.3.92-4.fc17,gnome-doc-utils-0.20.9-1.fc17,gnome-dvb-daemon-0.2.8-1.fc17,gnome-games-3.3.92-1.fc17,gnome-icon-theme-symbolic-3.3.91.1-1.fc17,gnome-keyring-3.3.92-1.fc17,gnome-online-accounts-3.3.92.1-1.fc17,gnome-packagekit-3.3.92-1.fc17,gnome-panel-3.3.92-1.fc17,gnome-power-manager-3.3.92-1.fc17,gnome-settings-daemon-3.3.92-1.fc17,gnome-shell-3.3.92-1.fc17,gnome-system-log-3.3.92-1.fc17,gnome-system-monitor-3.3.92-1.fc17,gnome-themes-standard-3.3.92-1.fc17,gobject-introspection-1.31.22-1.fc17,gsettings-desktop-schemas-3.3.92-1.fc17,gtk3-3.3.20-1.fc17,gtksourceview3-3.3.5-1.fc17,itstool-1.1.2-1.fc17,libgnome-keyring-3.3.92-1.fc17,libsoup-2.37.92-1.fc17,mousetweaks-3.3.92-1.fc17,mutter-3.3.92-1.fc17,nautilus-3.3.92-1.fc17,nautilus-sendto-3.0.2-1.fc17,orca-3.3.92-1.fc17,pyatspi-2.3.92-1.fc17,pygobject3-3.1.92-1.fc17,seahorse-3.3.92-1.fc17,simple-scan-3.3.92-1.fc17,sushi-0.3.92-2.fc17,totem-3.3.92-1.fc17,totem-pl-parser-3.3.92-1.fc17,vala-0.15.2-1.fc17,vinagre-3.3.92-1.fc17,vino-3.3.92-1.fc17,vte3-0.32.0-1.fc17,webkitgtk3-1.7.92-1.fc17,yelp-3.3.92-1.fc17,yelp-tools-3.3.4-1.fc17,yelp-xsl-3.3.92-1.fc17

Reopening until we have this verified and pushed to stable. It's better to use Bodhi to manage the bug state.
Comment 8 Kamil Páral 2012-03-26 09:12:02 EDT
Fix verified. Now we need to push to stable.

Note You need to log in before you can comment on or make changes to this bug.