This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 795804 - [RFE] Add NFSv4 support to kdump
[RFE] Add NFSv4 support to kdump
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.3
All Linux
high Severity high
: rc
: ---
Assigned To: Cong Wang
Zhiyou Liu
: FutureFeature
Depends On: 797174
Blocks: 807884 815596
  Show dependency treegraph
 
Reported: 2012-02-21 10:11 EST by Miguel Perez Colino
Modified: 2013-09-29 22:30 EDT (History)
3 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.0-232.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 807884 815596 (view as bug list)
Environment:
Last Closed: 2012-06-20 08:06:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
V1 patch (15.44 KB, patch)
2012-02-28 01:56 EST, Cong Wang
no flags Details | Diff
V2 patch (16.31 KB, patch)
2012-02-28 03:01 EST, Cong Wang
no flags Details | Diff

  None (edit)
Description Miguel Perez Colino 2012-02-21 10:11:14 EST
Description of problem:
When using kdump, the network destinations can only be NFSv3 or SSH with shell access.
The NFSv3 only destination requires extra network configuration to enable portmapping, compared to NFSv4. Adding this option would ease configuration and maintenance.
The SSH option launches remote commands, like mktemp, to perform the dump. The destination service cannot be restricted to SFTP or SCP only (and sometimes cannot be a different unix-like system, as happened with HP/UX).


Version-Release number of selected component (if applicable):


How reproducible:
Enable a remote system with NFSv4 only or SFTP only. Configure a local system to use that destination for kdump. Force a panic in the local system to make it try to dump in the remote system.

Steps to Reproduce:
1.Enable a remote system with NFSv4 only or SFTP only.
2.Configure a local system to use that destination for kdump.
3.Force a panic in the local system to make it try to dump in the remote system.
  
Actual results:
No dump is stored in the remote system.

Expected results:
Dump is stored in the remote system.

Additional info:
I'd suggest keeping "net" option in the kdump.conf file for backwards compatibility, and adding "nfs3", "nfs4", "ssh" and "sftp". In my dreams I even would include "rsync" (without ssh, pure rsync) :-D
Comment 3 Cong Wang 2012-02-28 01:56:25 EST
Created attachment 566220 [details]
V1 patch
Comment 5 Cong Wang 2012-02-28 03:01:08 EST
Created attachment 566238 [details]
V2 patch

Rename "nfs3" to "nfs", to sync with the names in "mount".
Comment 17 errata-xmlrpc 2012-06-20 08:06:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0758.html

Note You need to log in before you can comment on or make changes to this bug.