Bug 79592 - Kudzu causes kernel hardware Oops: 0002 on Sony Vaio laptops.
Kudzu causes kernel hardware Oops: 0002 on Sony Vaio laptops.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-13 13:55 EST by Need Real Name
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 09:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's the dmesg file from the laptop in question. (9 bytes, text/plain)
2002-12-13 14:06 EST, Need Real Name
no flags Details
Here's the dmesg file from the laptop in question. (9 bytes, application/octet-stream)
2002-12-13 14:09 EST, Need Real Name
no flags Details
output of dmesg (10.66 KB, text/plain)
2002-12-13 21:22 EST, ajs
no flags Details

  None (edit)
Description Need Real Name 2002-12-13 13:55:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
Kudzu causes a kernel fault on redhat 8.0 when installed on a Sony Vaio PCG-881R
laptop.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get a relatively new sony vaio laptop (pentium III based)
2. Install redhat 8.0
3. Watch in horror as kudzu makes the freshly installed laptop crash and burn.

Actual Results:  Kudzu causes a kernel Oops: 0002 error and the computer locks
up shortly afterwards.

The error message is as follows:
Checking for new hardwareOops: 0002
ohci1394 ieee1394 ide-scsi scsi_mod ide-cd cdrom mousedev keybdev hid inupt us
CPU:    0
EIP:    0010:[<d08f5d2a>]     Not tainted
EFLAGS: 00010046

EIP is at hpsb_remove_host_R34144dc5 [ieee1394] 0x3a (2.4.18-14)
eax: 00000000   ebx: c1396000   ecx:  00000246   edx: 00000000
esi: c1a82c20   edi: 00000000   ebp:  c1aec000   esp: cf143e7c
ds: 0018   es: 0018   ss: 0018
Process modprobe (pid: 304, stackpage=cf143000
Stack: c1396000 c13974ec 00000000 d0889ff8 c1396000 c13974ec c13974ec 00000000

Computer locks up at this point...... I have 6 of these laptops and the same
thing happens on all of them.

Expected Results:  Kudzu should have run normally and continued without
complaining.  This problem was not present with redhat 7.3

Additional info:
Comment 1 Need Real Name 2002-12-13 14:06:52 EST
Created attachment 88697 [details]
Here's the dmesg file from the laptop in question.

This dmesg file has the whole error in it.  It'll probably be more uesful.
Comment 2 Need Real Name 2002-12-13 14:09:30 EST
Created attachment 88698 [details]
Here's the dmesg file from the laptop in question.

This dmesg file has the whole error in it.  It'll probably be more uesful.
(last attempt at uploading it was no good, so I'm trying again.)
Comment 3 Need Real Name 2002-12-13 14:11:51 EST
Attachments aren't working right.  Is bugzilla broken or something?
Comment 4 ajs 2002-12-13 21:22:26 EST
Created attachment 88718 [details]
output of dmesg
Comment 5 ajs 2002-12-13 21:24:36 EST
The same thing happens with model PCG-GRX650
Comment 6 Moritz Baumann 2003-01-04 12:49:51 EST
same on Sony Vaio PCG-NV105

Steps to reproduce (and have a shell or something to file this report):

1) in grub menu edit the kernel line and append init 1
eg. kernel /boot/vmlinz-2.4.18-19.8.0 ro root=LABEL=/ hdc=ide-scsi init 1
2) in shell start kudzu
eg. 
sh-2.05b# kudzu
Ooops: 0002
ohci1934 iee1394 ide-scsi scsi_mod ide-cd cdrom loop ext3 jdb lvm-mod
CPU:      0
EIP:      0010:[<d08a3d2a>]       Not taintet
EFLAGS:   00010046

EIP is at hpsb_remove_host_R34144dc5 [iee1394] 0x3a (2.4.18-19.8.0)
eax: 00000000 ebx: cfeac000 ecx: 00000246 edx: 00000000
esi: c1889d40 edi: 00000000 ebp: c1aec800 esp: cf1a3e7c
ds: 0018 es: 0018 ss: 0018
Process modprobe (pid: ... stackpage cf1a3000)
Stack: ....

and the rest is more or less the same
similar trace
same Code in bottom line

---> the system is up to date (with up2date)
changed in /etc/sysconfig/kudzu :
SAFE=yes

I'm trying two things next taking kudzu out of the boot-process and see if it works

getting a vanilla-2.4.20 kernel and see if the problem remains.
...
I'll be back
;)
Comment 7 Moritz Baumann 2003-01-04 12:59:27 EST
initial workaround:

boot with an appended: init 1

chkconfig --list kudzu
chkconfig --level 2345 kudzu off
reboot

afterwards the system goes up fine.

Next step will be to replace kernel with vanilla 2.4.20

(btw. I don't like your policy Redhat to ship a kernel, where the kernel sources
do not match... most of the time I'm not able to recompile your kernel and have
to pick a vanilla).
Comment 8 Moritz Baumann 2003-01-06 19:43:08 EST
fyi: kudzu does not crash on vanilla 2.4.20 anymore.

(but this might be my custom kernel).

Moritz
Comment 9 Moritz Baumann 2003-02-07 08:06:40 EST
Installed Phoebe 8.0.92 and 8.0.93

both run out of the box without this bug
Comment 10 Alan Cox 2003-06-05 09:12:11 EDT
It was a problem with the firewire driver on some systems. Kudzu happeend to be the
apparent victim because it loaded the driver.

Note You need to log in before you can comment on or make changes to this bug.