Bug 796086 - Error Install grub2
Error Install grub2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-02-22 04:23 EST by Hongqing Yang
Modified: 2013-07-04 09:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: firstboot-17.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-01 04:53:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kickstart file (352 bytes, application/octet-stream)
2012-02-22 04:23 EST, Hongqing Yang
no flags Details
screenshot (1.35 KB, image/png)
2012-02-22 04:26 EST, Hongqing Yang
no flags Details
anaconda log (20.01 KB, text/plain)
2012-02-22 04:33 EST, Hongqing Yang
no flags Details
syslog (91.34 KB, text/plain)
2012-02-22 04:35 EST, Hongqing Yang
no flags Details
program log (34.63 KB, text/plain)
2012-02-22 04:35 EST, Hongqing Yang
no flags Details
storage log (91.22 KB, text/plain)
2012-02-22 04:36 EST, Hongqing Yang
no flags Details
install log (27.76 KB, text/plain)
2012-02-22 04:38 EST, Hongqing Yang
no flags Details
install log syslog (6.20 KB, text/plain)
2012-02-22 04:38 EST, Hongqing Yang
no flags Details
screenshot esc (14.78 KB, image/png)
2012-02-23 01:21 EST, Hongqing Yang
no flags Details

  None (edit)
Description Hongqing Yang 2012-02-22 04:23:22 EST
Created attachment 564882 [details]
kickstart file

Description of problem:
This is to cover test case
https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_Cmdline
after installation with ks file in the attachment, the system cannot reboot.
after being forced off and boot it, it also cannot boot into the system.
Not sure if it is the same with bug 787461. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hongqing Yang 2012-02-22 04:26:27 EST
Created attachment 564884 [details]
screenshot
Comment 2 Hongqing Yang 2012-02-22 04:33:37 EST
Created attachment 564888 [details]
anaconda log
Comment 3 Hongqing Yang 2012-02-22 04:35:04 EST
Created attachment 564890 [details]
syslog
Comment 4 Hongqing Yang 2012-02-22 04:35:36 EST
Created attachment 564891 [details]
program log
Comment 5 Hongqing Yang 2012-02-22 04:36:02 EST
Created attachment 564892 [details]
storage log
Comment 6 Hongqing Yang 2012-02-22 04:38:00 EST
Created attachment 564893 [details]
install log
Comment 7 Hongqing Yang 2012-02-22 04:38:24 EST
Created attachment 564894 [details]
install log syslog
Comment 8 Chris Lumens 2012-02-22 09:57:04 EST
The screenshot you're seeing has nothing to do with grub2 installation, or with anaconda at all.  Also in your program.log I specifically see that grub2 reports no errors.  Can you press escape when the system is hung up booting so we can see exactly where in the process it's stuck?
Comment 9 Hongqing Yang 2012-02-23 01:21:19 EST
Created attachment 565196 [details]
screenshot esc

sometimes the guest can reboot after installation, but during the reboot, it still halts.
Comment 10 Chris Lumens 2012-02-23 09:58:15 EST
Looks like systemd and text mode firstboot don't really get along.
Comment 11 Martin Gracik 2012-02-24 03:37:02 EST
What version of firstboot is there? There should not be a text mode firstboot in Fedora 17.

Note You need to log in before you can comment on or make changes to this bug.