Bug 796261 - Bootloader not installed? (F17 Alpha RC4)
Summary: Bootloader not installed? (F17 Alpha RC4)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-22 15:18 UTC by Jaroslav Reznik
Modified: 2012-07-19 18:46 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-19 18:46:10 UTC


Attachments (Terms of Use)
program.log (211.46 KB, text/x-log)
2012-02-22 15:23 UTC, Jaroslav Reznik
no flags Details
anaconda.log (18.14 KB, text/x-log)
2012-02-22 15:24 UTC, Jaroslav Reznik
no flags Details
storage.log (369.53 KB, text/x-log)
2012-02-22 19:04 UTC, Jaroslav Reznik
no flags Details
new storage.log for failed install (410.39 KB, application/octet-stream)
2012-02-22 20:17 UTC, Jaroslav Reznik
no flags Details
anaconda.program.log (211.44 KB, application/octet-stream)
2012-02-22 20:42 UTC, Jaroslav Reznik
no flags Details
new anaconda.log (16.08 KB, application/octet-stream)
2012-02-22 20:44 UTC, Jaroslav Reznik
no flags Details

Description Jaroslav Reznik 2012-02-22 15:18:16 UTC
Description of problem: bootloader is not installed correctly, unable to boot after installation on Lenovo T520 with Intel's SSD drive. Legacy boot option selected.

Works correctly with F16.

Version-Release number of selected component (if applicable):
Alpha RC4

Steps to Reproduce:
1. prepare USB stick with livecd-iso-to-disk
2. install
3. reboot
  
Actual results:
Fedora doesn't boot.

Expected results:
Fedora boots.

Comment 1 Jaroslav Reznik 2012-02-22 15:23:17 UTC
Created attachment 565008 [details]
program.log

Comment 2 Jaroslav Reznik 2012-02-22 15:24:33 UTC
Created attachment 565009 [details]
anaconda.log

Comment 3 Rex Dieter 2012-02-22 15:37:44 UTC
burned Fedora-17-Alpha-x86_64-Live-KDE.iso to cd, booted, ran installer.  Only slightly modified default setup:
no lvm
deleted extra /home (put all in / partition)

bootloader config set for boot sector of boot partition (instead of mbr).


After install, rebooted, but see nothing but blinking cursor like reporter here. :(

Comment 4 Rex Dieter 2012-02-22 16:06:20 UTC
installing default partioning/bootloader options worked, maybe I simply saw a
variation of bug #794957

Comment 5 David Lehman 2012-02-22 16:24:49 UTC
Jaroslav, please also attach /tmp/storage.log (or /var/log/anaconda/anaconda.storage.log). Thanks.

Comment 6 Adam Williamson 2012-02-22 16:32:46 UTC
Rex: sorry for the stupid question, but did you actually have a bootloader in the MBR before you tried to install? If so, what bootloader, installed by what OS?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 Rex Dieter 2012-02-22 16:38:21 UTC
I started with a blank/new disk in this case (in comment #3)

Comment 8 David Lehman 2012-02-22 17:11:04 UTC
(In reply to comment #7)
> I started with a blank/new disk in this case (in comment #3)

Rex, you are describing bug 794957. Please go there if you want to comment further. In this bug report we are trying to identify the problem Jaroslav reported, which does not involve installing the bootloader to the first sector of a partition, but rather to the MBR.

Setting NEEDINFO(reporter) again to get storage.log.

Comment 9 David Lehman 2012-02-22 17:12:47 UTC
(In reply to comment #3)
> bootloader config set for boot sector of boot partition (instead of mbr).
> 
> 
> After install, rebooted, but see nothing but blinking cursor like reporter
> here. :(

This requires a bootloader in the MBR. The only way to boot from the first sector of the boot partition is by chainloading from the main (MBR) bootloader.

Comment 10 Adam Williamson 2012-02-22 17:38:52 UTC
Right, Rex's case is user error. We should stick to Jaro's and Reartes' issues. Jaro says he'll provide storage.log soon.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 11 Jaroslav Reznik 2012-02-22 19:04:29 UTC
Created attachment 565068 [details]
storage.log

Btw. this is storage.log from another install (I wiped out first one while trying next round).

Comment 12 Jaroslav Reznik 2012-02-22 19:10:21 UTC
Actually the #11 storage.log is from working configuration - I did not changed anything in the setup but it just boots now... NOT A BUG? But still I wonder what was different this time.

Comment 13 Adam Williamson 2012-02-22 20:10:37 UTC
Proposing as an Alpha blocker just so we track this for the go/no-go. It's *potentially* a blocker but we need to know what the hell's going wrong. jaro says his latest attempts are back to failure, I've asked him to attach logs.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 14 Jaroslav Reznik 2012-02-22 20:17:48 UTC
Created attachment 565089 [details]
new storage.log for failed install

Comment 15 Jaroslav Reznik 2012-02-22 20:42:23 UTC
Created attachment 565098 [details]
anaconda.program.log

As Adam asked me to re-upload the failed ones logs together.

Comment 16 Jaroslav Reznik 2012-02-22 20:44:03 UTC
Created attachment 565099 [details]
new anaconda.log

Comment 17 Adam Williamson 2012-02-22 21:54:27 UTC
My vote on this is -1 blocker: it's a bad result but we have no other reports of this fail, and several reports of success, which leads me to believe it's specific to Jaro's system. We'd love to know what's causing it, though.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 18 Tim Flink 2012-02-22 22:02:47 UTC
I'm -1 alpha blocker on this for similar reasons that adam lists in c#17.

It seems to be isolated in contrast with several successful results.

Comment 19 Robyn Bergeron 2012-02-22 22:08:34 UTC
I am with Tim and Adam on -1 alpha blocker; not having any reproduction with other successes. Would like to see some work on tracking it down but not feeling blockerish.

Comment 20 Tim Flink 2012-02-22 22:25:29 UTC
Discussed in the 2012-02-22 Fedora 17 Alpha Go/No-Go meeting. Agreed that this
seems to be an isolated incident and not an indicator of a larger problem.

As such, it is rejected as a blocker for Fedora 17 alpha.

Comment 21 Adam Williamson 2012-05-08 06:21:35 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 22 Jesse Keating 2012-07-19 18:46:10 UTC
Since there hasn't been activity here since prior to the alpha I assume that this problem has gone away.  Please re-open (or file a new bug) if the problem is still present.


Note You need to log in before you can comment on or make changes to this bug.