Bug 796273 - Priority ring queue lets lower-priority message displace higher-priority
Summary: Priority ring queue lets lower-priority message displace higher-priority
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 2.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: 3.1
: ---
Assignee: Gordon Sim
QA Contact: Matej Lesko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-22 15:29 UTC by Alan Conway
Modified: 2015-04-14 13:46 UTC (History)
4 users (show)

Fixed In Version: qpid-cpp-0.22
Doc Type: Bug Fix
Doc Text:
A Ring Priority queue works by removing the lowest priority message if the queue limit is reached. It was discovered that the queue did not take into account whether the new message was a lower priority than the one being removed. A lower priority message could therefore displace a higher-priority message. A fix to the Priority Ring queue now correctly assesses the incoming message priority, and ensures that higher priority messages remain in the queue.
Clone Of:
Environment:
Last Closed: 2015-04-14 13:46:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
Test case (580 bytes, text/x-python)
2012-02-22 15:30 UTC, Alan Conway
no flags Details


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-3866 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Description Alan Conway 2012-02-22 15:29:53 UTC
Description of problem:

Currently a ring+priority queue works by removing the lowest priority message if the limit is reached. However it does not consider whether the new message is actually of lower priority than the one being displaced. A lower priority message should not displace a higher-priority message.


Version-Release number of selected component (if applicable): 0-14


How reproducible: 100%


Steps to Reproduce: Run attached python test.
  
Actual results: fails - priority 2 message displaces priority 8 message

Expected results: passes

Comment 1 Alan Conway 2012-02-22 15:30:43 UTC
Created attachment 565017 [details]
Test case

Comment 2 Gordon Sim 2013-04-25 11:41:52 UTC
Fixed in qpid 0.20 as part of broker refactor.

Comment 5 Matej Lesko 2015-02-16 12:27:06 UTC
Added test names.

Comment 7 errata-xmlrpc 2015-04-14 13:46:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.