Bug 796311 - OpenVRML with libpng 1.5 and against recent XULRunner
Summary: OpenVRML with libpng 1.5 and against recent XULRunner
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openvrml (Show other bugs)
(Show other bugs)
Version: 17
Hardware: All Linux
unspecified
medium
Target Milestone: ---
Assignee: Braden McDaniel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-22 16:52 UTC by Pavel Tisnovsky
Modified: 2012-05-26 22:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 22:21:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mozilla-plugin API patch (662 bytes, patch)
2012-02-22 16:58 UTC, Pavel Tisnovsky
no flags Details | Diff
libpng15 patch (1.71 KB, patch)
2012-02-22 16:58 UTC, Pavel Tisnovsky
no flags Details | Diff
Patch for javascript.cpp (3.54 KB, patch)
2012-02-23 15:31 UTC, Pavel Tisnovsky
no flags Details | Diff

Description Pavel Tisnovsky 2012-02-22 16:52:50 UTC
Description of problem:

OpenVRML can not be build in F17 mock due to several issues:

1) changes in Mozilla plugin API
2) changes in libpng15 API
3) changes in JSAPI

Patches to fix these issues will follow...

Comment 1 Pavel Tisnovsky 2012-02-22 16:58:05 UTC
Created attachment 565040 [details]
Mozilla-plugin API patch

Comment 2 Pavel Tisnovsky 2012-02-22 16:58:33 UTC
Created attachment 565042 [details]
libpng15 patch

Comment 3 Pavel Tisnovsky 2012-02-23 15:31:37 UTC
Created attachment 565323 [details]
Patch for javascript.cpp

Comment 4 Braden McDaniel 2012-04-26 22:59:59 UTC
This doesn't appear to have anything to do with OpenJDK; changing summary accordingly.

Comment 5 Fedora Update System 2012-05-13 06:25:05 UTC
openvrml-0.18.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openvrml-0.18.9-1.fc17

Comment 6 Fedora Update System 2012-05-14 00:42:01 UTC
Package openvrml-0.18.9-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openvrml-0.18.9-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7807/openvrml-0.18.9-1.fc17
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-05-18 20:25:06 UTC
Package openvrml-0.18.9-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openvrml-0.18.9-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7807/openvrml-0.18.9-3.fc17
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2012-05-26 22:21:18 UTC
openvrml-0.18.9-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.