Bug 79632 - bad source code
bad source code
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: cdrtools (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-14 05:20 EST by d.binderman
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-25 13:39:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2002-12-14 05:20:31 EST
Description of problem:

Hello there,

I just tried to compile package cdrtools-1.10-14 from Redhat 8.0.

Here are some of the compiler messages.

comerr.c:169: warning: unknown conversion type character `r' in format
comerr.c:177: warning: unknown conversion type character `r' in format
error.c:46: warning: unknown conversion type character `r' in format
serrmsg.c:104: warning: unknown conversion type character `r' in format
serrmsg.c:113: warning: unknown conversion type character `r' in format
scsitransp.c:1290: warning: unknown conversion type character `r' in format
cdda2wav.c:578: warning: unknown conversion type character `r' in format
cdda2wav.c:604: warning: unknown conversion type character `r' in format
io.c:205: warning: unknown conversion type character `r' in format

Normally, I would have tried to supply a patch, but since both I and
the compiler do not know what %r is supposed to mean, then I am unable
to supply a patch in this case.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Mike A. Harris 2003-01-24 11:35:10 EST
I've just successfully recompiled this package on a fresh Red Hat Linux 8.0
install, by taking the source code RPM package and doing:

rpm --rebuild <packagename>

It built successfully, and installed.  I can only assume that you are not
using the Red Hat supplied compiler, and are using some third party compiler,
or you have modified the package(s) in some way that is incompatible.

At any rate, this works for me.
Comment 2 d.binderman 2003-01-25 06:50:20 EST
I'm sorry, but I forgot to mention that you need to supply
compile flags "-g -O2 -Wall" to get the compiler to complain.

My apologies for this - I've found so many bugs in Redhat
Linux 8.0 (60+ so far) that I'm starting to get sloppy in reporting
them.

What does %r mean anyway ?
Comment 3 Mike A. Harris 2003-01-25 13:39:43 EST
The software compiles, does so properly, and when it is done compiling,
it works, and works properly.  The packages we ship are properly functional.

Red Hat does not offer technical support via bugzilla, nor do we offer
technical support to people recompiling the software we ship.  If you
have problems recompiling something, or questions about compiler warnings
that you receive recompiling something, the proper place to ask these
questions is on a mailing list of some kind.  The best suggestion would
be to get in contact with the upstream developers of the software you
are trying to compile, and discuss the issue with their source code
directly with them.

Do not file technical support requests in bugzilla.

Closing NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.