Bug 796381 - Unable to upload a CLI alert script using the Upload mechanism on the Repository detail page
Unable to upload a CLI alert script using the Upload mechanism on the Reposit...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.3
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: JON 3.0.1
Assigned To: Lukas Krejci
Mike Foley
:
Depends On: 794768 840650
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-22 14:27 EST by Lukas Krejci
Modified: 2012-11-27 15:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 794768
Environment:
Last Closed: 2012-02-27 17:40:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lukas Krejci 2012-02-22 14:27:50 EST
+++ This bug was initially created as a clone of Bug #794768 +++

Description of problem:
$SUBJECT

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Create a repository
2. Scroll down, upload a js script
3. select type of "Serverside CLI Script"
4. Click "Create Package" button
  
Actual results:
exception complaining that a sha256 hash is not an OSGi version string (which it isn't)

Expected results:
upload should work

Additional info:
This exception is most likely caused by the validation the CLI package type performs on the version string.
Not sure what the solution should be here though. Using sha256 as a version string makes a lot of sense (as we've seen lately) but at the same time the validation (of CLI package type versions )that is in place right now does a good deal of user visible version validation. Maybe we could just change the validator to check the display version instead of the version field?

--- Additional comment from lkrejci@redhat.com on 2012-02-17 10:12:54 EST ---

Stefan, what is your opinion on this?

--- Additional comment from lkrejci@redhat.com on 2012-02-17 10:17:29 EST ---

The uploading using the CLI alert notification definition popup while defining an alert definition still works though...
Comment 1 Lukas Krejci 2012-02-22 14:29:00 EST
Note that this is a documented feature in JON and a regression from JON 3.0.0.
Comment 2 Mike Foley 2012-02-27 10:47:22 EST
triage to JON 3.1 mfoley,crouch
Comment 3 Mike Foley 2012-02-27 12:13:09 EST
triage 2/27/2012 mfoley, asantos, crouch, loleary

Note You need to log in before you can comment on or make changes to this bug.