Bug 796408 - Add detection of PowerPath devices to LVM
Summary: Add detection of PowerPath devices to LVM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 6.3
Assignee: Alasdair Kergon
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 607248
TreeView+ depends on / blocked
 
Reported: 2012-02-22 20:16 UTC by Guil Barros
Modified: 2018-12-03 17:29 UTC (History)
11 users (show)

Fixed In Version: lvm2-2.02.95-1.el6
Doc Type: Bug Fix
Doc Text:
LVM now recognises PowerPath devices ("emcpower") and uses them in preference to the devices out of which they are constructed.
Clone Of:
Environment:
Last Closed: 2012-06-20 15:01:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0962 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2012-06-19 21:12:11 UTC

Description Guil Barros 2012-02-22 20:16:29 UTC
Description of problem:
LVM will currently pick a path for a pv instead of the powerpath device. The functionality requested is for lvm to notice the emcpower device and hook up to that instead. This is already committed upstream here:

http://sourceware.org/cgi-bin/cvsweb.cgi/LVM2/lib/filters/filter.c.diff?r1=1.66&r2=1.67&cvsroot=lvm2

Version-Release number of selected component (if applicable):
lvm2-2.02.87-6.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Configure a system with EMC PowerPath as the mp driver
2. use lvm
  
Actual results:
# pvscan -v
    Wiping cache of LVM-capable devices
    Wiping internal VG cache
    Walking through all physical volumes
  PV /dev/cciss/c0d2p1    VG rootvg          lvm2 [33.91 GiB / 0    free]
  PV /dev/sda   VG vg1         lvm2 [34.69 GiB / 0    free]
...

Expected results:
# pvscan -v
    Wiping cache of LVM-capable devices
    Wiping internal VG cache
    Walking through all physical volumes
  PV /dev/cciss/c0d2p1    VG rootvg          lvm2 [33.91 GiB / 0    free]
  PV /dev/emcpoweraa   VG vg1         lvm2 [34.69 GiB / 0    free]
...

Comment 7 errata-xmlrpc 2012-06-20 15:01:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0962.html

Comment 8 Ademar Reis 2012-07-11 14:33:04 UTC
*** Bug 825920 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.