Bug 796409 - iwhd fails on F16
Summary: iwhd fails on F16
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: iwhd
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
Assignee: Pete Zaitcev
QA Contact: Brad P. Crochet
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-22 20:17 UTC by Matt Wagner
Modified: 2014-08-17 22:27 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-13 19:50:19 UTC


Attachments (Terms of Use)

Description Matt Wagner 2012-02-22 20:17:58 UTC
Description of problem:
On a fresh install of F16, if I install aeolus-all (which includes iwhd), and then run aeolus-configure, iwhd fails to start:

[root@localhost ~]# sudo service iwhd status
iwhd.service - Image Warehouse
	  Loaded: loaded (/lib/systemd/system/iwhd.service; enabled)
	  Active: failed since Wed, 22 Feb 2012 14:58:47 -0500; 12min ago
	 Process: 3652 ExecStart=/usr/bin/iwhd $IWHD_ARGS (code=dumped, signal=SEGV)
	  CGroup: name=systemd:/system/iwhd.service

There is no /var/log/iwhd.log file.


Version-Release number of selected component (if applicable):
aeolus-all.noarch 0.4.0-1.fc16
iwhd.x86_64 1.2-1.fc16

How reproducible:
100% for me and also jclift

Steps to Reproduce:
1. Provision F16 installation
2. yum install aeolus-all
3. aeolus-configure # will fail with errors starting iwhd
4. service iwhd status
  
Actual results:
iwhd fails with an error hinting at some sort of segfault

Expected results:
iwhd starts normally

Additional info:
I haven't seen this happen on other platforms, so this has probably been fixed long ago and just not included in the Fedora 16 packages. This is a big problem, though, because it keeps Aeolus from being usable to new users on F16.

Comment 1 jrd 2012-02-22 20:32:25 UTC
To my knowledge F16 is not on the list of supported platforms for CF.  So this shouldn't be treated as a blocker.

That said, there's no reason for it to be gratuitously broken.  Pete?

Comment 2 Jim Meyering 2012-02-22 22:02:20 UTC
Thanks for the report, Matt.

This appears to be due to changes in boost.
iwhd doesn't even get through its configure script on F16, now.
It dies because the latest boost headers now choke the C++ preprocessor
with an #error if you're not compiling with -pthread.  Our test for
whether to use -pthread involves compiling without the option for
which we're probing.

This appears related:

    https://svn.boost.org/trac/boost/ticket/6165

I'll dig more tomorrow.

Comment 3 Jim Meyering 2012-02-23 15:34:13 UTC
The build failures I mentioned arise only when using g++-4.7.x.
With F16's /usr/bin/g++, iwhd does still build.
However, the result fails each and every mongo-using test.

The problem there is that mongod was taking more than
the 5-seconds the test allotted for it to start up.
In practice, with the new DB initialization it does,
it now takes ~15 seconds to become usable, and far more
when you run the tests in parallel and it's trying to
initialize 5 or 10 separate DBs at once.  In addition,
the disk space requirements have now gone way up,
especially when running the tests in parallel.
For example, "make -j1 check" passes once I've increased
the timeout value from 5 to 30 seconds, but several tests
fail in mysterious ways when you do "make -j4 check".

Comment 4 Matt Wagner 2012-02-29 22:55:52 UTC
Hi Jim,

For what it's worth (and if you're not already aware of this), this appears to work just fine with iwhd-1.2-3 available in the Aeolus testing repo: http://repos.fedorapeople.org/repos/aeolus/conductor/testing/fedora-16/x86_64/

It's just the version available in native F16 that does not work.

Comment 5 Justin Clift 2012-03-05 14:04:26 UTC
Hi guys,

Can we get iwhd-1.2-3 into mainline Fedora 16 updates?  It does work, unlike the version presently there. :)

If not, what's the way forward?

End users coming from Fedora 16 are completely unable to use Aeolus (ie blocker) due to this. :(

Comment 6 Jim Meyering 2012-03-05 14:21:56 UTC
I'm about to release 1.4, which includes a fix for 798786, so expect it very soon, probably today.

Comment 7 Jim Meyering 2012-03-06 20:40:15 UTC
this is now fixed in F16

Comment 9 Martin Kočí 2012-03-27 15:28:24 UTC
[root@nec-em18 ~]# service iwhd status
iwhd.service - Image Warehouse
          Loaded: loaded (/lib/systemd/system/iwhd.service; enabled)
          Active: active (running) since Tue, 27 Mar 2012 11:08:45 -0400; 17min ago
        Main PID: 2753 (iwhd)
          CGroup: name=systemd:/system/iwhd.service
                  └ 2753 /usr/bin/iwhd -c /etc/iwhd/conf.js -l /var/log/iwhd.log
[root@nec-em18 ~]# rpm -q aeolus-all
aeolus-all-0.9.0-0.20120326215437gitd951bad.fc16.noarch
[root@nec-em18 ~]# rpm -q iwhd
iwhd-1.4-1.fc16.x86_64
[root@nec-em18 ~]# cat /etc/redhat-release 
Fedora release 16 (Verne)

successfully passed aeolus-configure. 
Moving bug to VERIFIED

Comment 10 Mike Orazi 2012-08-09 15:28:59 UTC
This is a fedora bug, removing from the product list.


Note You need to log in before you can comment on or make changes to this bug.