Bug 79645 - Nautilus and Metacity icons get messed up
Nautilus and Metacity icons get messed up
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://mirror.n3dst4.com/brokenicons/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-14 06:46 EST by Neil de Carteret
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 08:28:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Busted nautilus icons from my desktop (24.59 KB, image/png)
2002-12-14 06:47 EST, Neil de Carteret
no flags Details
Busted Bluecurve/metacity icons (8.50 KB, image/png)
2002-12-14 06:48 EST, Neil de Carteret
no flags Details
More busted icons (26.72 KB, image/png)
2002-12-14 06:55 EST, Neil de Carteret
no flags Details

  None (edit)
Description Neil de Carteret 2002-12-14 06:46:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
Nautilus's icons get confused when any window is dragged over them; little bits
of other icons show up, half of one icon, or an entire other icon squashed into
one corner. Mousing over the icons fixes them until something perturbs them
again. See broken-icons.png (att.) to see the effect.

Metacity's window-border icons also suffer in similar ways, showing nothing, the
wrong icon or just detritus. See broken-window-icons.png (att.) In this case
mousing over fixes them , but only while the mouse is there - as soon as the
mouse leaves the window they spring back to brokeness. I have noticed that it's
only the focused window that gets this - as soon as another window gets the
focus, the (now greyed out) icons look okay.

Sawfish's icons do not do this. No other graphical corruption is evident anywhere.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Drag a window past a desktop icon or an icon in Nautilus
    or
2. Play with the window icons
Comment 1 Neil de Carteret 2002-12-14 06:47:53 EST
Created attachment 88721 [details]
Busted nautilus icons from my desktop
Comment 2 Neil de Carteret 2002-12-14 06:48:34 EST
Created attachment 88722 [details]
Busted Bluecurve/metacity icons
Comment 3 Neil de Carteret 2002-12-14 06:55:53 EST
Created attachment 88723 [details]
More busted icons

I just added this to demonstrate that the visual corruption is not the same
every time, and seems to involve a certain amount of recycling - note how the
first icon in this shot (coincidentally called "normal.log") is sound, the next
two wrongly get the same icon as the first one (with corruption), then my RPMS
directory is totally exploded - I think I can see elements from five different
icons in there, with that icon from "normal.log" showing up again.
Comment 4 Havoc Pennington 2002-12-14 10:36:48 EST
This says "X server bug" to me.

What video card do you have, what version of XFree86, and what driver are you using?
Comment 5 Neil de Carteret 2002-12-14 11:18:22 EST
Card:      Inno3d GeForce 3 Ti200
X version: XFree 4.2.0
Driver:    Tried both standard nv and and latest nvidia

I must stress that it isn't happening in Sawfish, and there's no other
corruption anywhere. I've just seen, though, that it happens in the Gnome menu's
icons - it's just that they're smaller so I guess I hadn't noticed before. Is
there something here that Metacity and Nautilus use that Sawfish doesn't?

I shall install KDE and report back.
Comment 6 Neil de Carteret 2002-12-14 11:27:47 EST
Okay, it was hardly extensive testing but I logged in with KDE, surfed a bit
(knackering my Mozilla 1.2.1 profile because I hit the original web browser icon
>_< ), played with Konqueror, dragged things round, opened lots of windows and
it was all fine.
Comment 7 Mike A. Harris 2002-12-15 03:19:25 EST
The "Nvidia" proprietary driver is not supported at all by Red Hat, and any
bugs you encounter while using their driver, or after using their driver
prior to a fresh system reboot without reloading their driver or kernel module,
should be reported directly to Nvidia.  We do not have the source code for
their driver, and are unable to do anything about bugs in their driver.

For the "nv" driver, however it is slightly different.  You need to configure
XFree86 to use the "nv" driver that comes with XFree86, remove any special
configuration options from your config file that are present just for
the proprietary Nvidia driver, and reboot your computer into runlevel 3
ensuring that the nvdriver kernel module is never loaded, nor any other
proprietary or 3rd party kernel modules.

After that, please reproduce this problem with our supplied driver, and
then attach your X config file, log file, /var/log/messages, and the output
of "lsmod" as well as the output of "lspci -vvn".

Thanks.
Comment 8 Neil de Carteret 2002-12-15 08:28:31 EST
I beg forgiveness.
I had gone back to nv but only restarted X, so the nVidia kernel module was
still loaded. I'll take this over to nVidia's site.

As you were.
Comment 9 Havoc Pennington 2002-12-15 13:20:22 EST
metacity/nautilus probably use the RENDER extension for accelerated image 
rendering, KDE and Sawfish may not. This extension is perhaps broken 
with your drivers.

Note You need to log in before you can comment on or make changes to this bug.