This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 796511 - RuntimeError: Error running btrfs: No such file or directory
RuntimeError: Error running btrfs: No such file or directory
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
abrt_hash:a4560e942f65a3f6ee612b10a3e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-22 22:44 EST by Clyde E. Kunkel
Modified: 2013-07-04 09:01 EDT (History)
8 users (show)

See Also:
Fixed In Version: lorax-17.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 05:23:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb-JDOtQY (537.22 KB, text/plain)
2012-02-22 22:44 EST, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2012-02-22 22:44:34 EST
libreport version: 2.0.8
cmdline:        /usr/bin/python  /sbin/anaconda --graphical --selinux --repo cdrom:///dev/sr1:/mnt/install/source
executable:     /sbin/anaconda
exnFileName:    /tmp/anaconda-tb-JDOtQY
hashmarkername: anaconda
kernel:         3.3.0-0.rc3.git7.2.fc17.x86_64
other involved packages: 
product:        Fedora
reason:         RuntimeError: Error running btrfs: No such file or directory
release:        Cannot get release name.
time:           Wed 22 Feb 2012 10:43:36 PM UTC
version:        17-Alpha

anaconda-tb-JDOtQY: Binary file, 550111 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.11 exception report
:Traceback (most recent call first):
:  File "/tmp/updates/pyanaconda/iutil.py", line 245, in execWithCapture
:    raise RuntimeError, "Error running " + command + ": " + e.strerror
:  File "/tmp/updates/pyanaconda/storage/devicelibs/btrfs.py", line 46, in btrfs
:    ret = exec_func("btrfs", args, **kwargs)
:  File "/tmp/updates/pyanaconda/storage/devicelibs/btrfs.py", line 113, in list_subvolumes
:    buf = btrfs(args, capture=True)
:  File "/tmp/updates/pyanaconda/storage/devices.py", line 4034, in listSubVolumes
:    subvols = btrfs.list_subvolumes(self.format._mountpoint)
:  File "/tmp/updates/pyanaconda/storage/devicetree.py", line 1587, in handleBTRFSFormat
:    for subvol_dict in btrfs_dev.listSubVolumes():
:  File "/tmp/updates/pyanaconda/storage/devicetree.py", line 1713, in handleUdevDeviceFormat
:    self.handleBTRFSFormat(info, device)
:  File "/tmp/updates/pyanaconda/storage/devicetree.py", line 1077, in addUdevDevice
:    self.handleUdevDeviceFormat(info, device)
:  File "/tmp/updates/pyanaconda/storage/devicetree.py", line 2006, in _populate
:    self.addUdevDevice(dev)
:  File "/tmp/updates/pyanaconda/storage/devicetree.py", line 1896, in populate
:    self._populate(progressWindow)
:  File "/tmp/updates/pyanaconda/storage/__init__.py", line 473, in reset
:    cleanupOnly=cleanupOnly)
:  File "/tmp/updates/pyanaconda/storage/__init__.py", line 102, in storageInitialize
:    storage.reset()
:  File "/tmp/updates/pyanaconda/dispatch.py", line 383, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/tmp/updates/pyanaconda/dispatch.py", line 247, in go_forward
:    self.dispatch()
:  File "/tmp/updates/pyanaconda/gui.py", line 1200, in nextClicked
:    self.anaconda.dispatch.go_forward()
:RuntimeError: Error running btrfs: No such file or directory

environ:
:LC_NUMERIC=C
:LANGKEY=en
:LVM_SUPPRESS_FD_WARNINGS=1
:initrd=initrd.img
:GCONF_GLOBAL_LOCKS=1
:PATH=/tmp/product:/tmp/updates:/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:HOME=/tmp
:LD_LIBRARY_PATH=/tmp/product:/tmp/updates
:LANG=en_US.UTF-8
:TERM=linux
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:LIBUSER_CONF=/tmp/libuser.KvgLv4
:DISPLAY=:1
:GNOME_DISABLE_CRASH_DIALOG=1
:PYTHONPATH=/tmp/product:/tmp/updates:/tmp/updates
:LINGUAS=English
:updates=http://dlehman.fedorapeople.org/updates/updates-796013.0.img
:BOOT_IMAGE=vmlinuz
:LC_COLLATE=C
:PWD=/
:MALLOC_PERTURB_=MALLOC_PERTURB_=18
:MALLOC_CHECK_=2
Comment 1 Clyde E. Kunkel 2012-02-22 22:44:38 EST
Created attachment 565170 [details]
File: anaconda-tb-JDOtQY
Comment 2 Clyde E. Kunkel 2012-02-22 22:50:07 EST
Had: http://dlehman.fedorapeople.org/updates/updates-796013.0.img installed also. Error occured during initial storage scan. Have an existing Fedora 15 installation on a btrfs LV.
Comment 3 Chris Lumens 2012-02-23 10:16:20 EST
Looks like a lorax problem:

share/runtime-cleanup.tmpl:removefrom btrfs-progs /sbin/btrfs /sbin/btrfs-* /sbin/btrfstune
Comment 4 Clyde E. Kunkel 2012-02-23 10:45:18 EST
Any workaround in the meantime?  Thx.
Comment 5 David Lehman 2012-02-23 18:12:46 EST
(In reply to comment #4)
> Any workaround in the meantime?  Thx.

Here's an updates image that includes the btrfs utility along with a fix for bug 796013. You still won't be able to work with your btrfs volumes in the custom partitioning interface, but you can install around them if that's an option.

 http://dlehman.fedorapeople.org/updates/updates-796511.0.img
Comment 6 Ian Pilcher 2012-02-23 20:57:55 EST
(In reply to comment #5)
> Here's an updates image that includes the btrfs utility along with a fix for
> bug 796013. You still won't be able to work with your btrfs volumes in the
> custom partitioning interface, but you can install around them if that's an
> option.
> 
>  http://dlehman.fedorapeople.org/updates/updates-796511.0.img

I just tried installing with this update, and anaconda appears to hang at the "Examining Devices" stage.  No CPU utilization, no disk activity, nothing being logged on any of the VTs or to any log file, and no D-state processes that I can find.
Comment 7 Clyde E. Kunkel 2012-02-24 14:05:52 EST
(In reply to comment #5)
> 
> Here's an updates image that includes the btrfs utility along with a fix for
> bug 796013. You still won't be able to work with your btrfs volumes in the
> custom partitioning interface, but you can install around them if that's an
> option.
> 
>  http://dlehman.fedorapeople.org/updates/updates-796511.0.img

Works nicely.  Thanks.
Comment 8 Ian Pilcher 2012-02-25 13:45:55 EST
(In reply to comment #6)
> I just tried installing with this update, and anaconda appears to hang at the
> "Examining Devices" stage.  No CPU utilization, no disk activity, nothing being
> logged on any of the VTs or to any log file, and no D-state processes that I
> can find.

I have converted my btrfs filesystem to ext4, and I'm still having this problem, so it appears to be unrelated.  I have created bug 797422 to track.

Note You need to log in before you can comment on or make changes to this bug.