Bug 796638 - Apache-commons-dbcp should not depend on OpenJDK6
Apache-commons-dbcp should not depend on OpenJDK6
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: apache-commons-dbcp (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Spike
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 06:26 EST by Pavel Tisnovsky
Modified: 2012-03-13 14:33 EDT (History)
3 users (show)

See Also:
Fixed In Version: java-1.5.0-gcj-1.5.0.0-39.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 14:33:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch in git-format which ensures that this package can be build by OpenJDK7 (19.71 KB, application/octet-stream)
2012-02-23 06:26 EST, Pavel Tisnovsky
no flags Details

  None (edit)
Description Pavel Tisnovsky 2012-02-23 06:26:46 EST
Created attachment 565277 [details]
Patch in git-format which ensures that this package can be build by OpenJDK7
Comment 1 Pavel Tisnovsky 2012-02-23 06:28:49 EST
The patch adds method declaration which were added to Java 1.7 API. All such methods throw SQLFeatureNotSupportedException ATM.
Comment 2 Spike 2012-02-23 06:41:20 EST
Thanks a lot for the patch. Could you file a bug report upstream and include the patch, since you're probably the go-to guy for this?
Comment 3 Deepak Bhole 2012-03-01 09:51:58 EST
Hi Spike -- will you be building dbcp with the above patch? If not, I don't mind doing it.. please let me know.
Comment 4 Fedora Update System 2012-03-09 16:38:23 EST
java-1.5.0-gcj-1.5.0.0-39.fc17,opticalraytracer-2.7-4.fc17,nyquist-3.04-4b.fc17.1,jide-oss-2.7.6-6.1340svn.fc17,xmlgraphics-commons-1.4-5.fc17,apache-commons-dbcp-1.4-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/java-1.5.0-gcj-1.5.0.0-39.fc17,opticalraytracer-2.7-4.fc17,nyquist-3.04-4b.fc17.1,jide-oss-2.7.6-6.1340svn.fc17,xmlgraphics-commons-1.4-5.fc17,apache-commons-dbcp-1.4-9.fc17
Comment 5 Fedora Update System 2012-03-09 20:23:09 EST
Package java-1.5.0-gcj-1.5.0.0-39.fc17, opticalraytracer-2.7-4.fc17, nyquist-3.04-4b.fc17.1, jide-oss-2.7.6-6.1340svn.fc17, xmlgraphics-commons-1.4-5.fc17, apache-commons-dbcp-1.4-9.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing java-1.5.0-gcj-1.5.0.0-39.fc17 opticalraytracer-2.7-4.fc17 nyquist-3.04-4b.fc17.1 jide-oss-2.7.6-6.1340svn.fc17 xmlgraphics-commons-1.4-5.fc17 apache-commons-dbcp-1.4-9.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3509/java-1.5.0-gcj-1.5.0.0-39.fc17,opticalraytracer-2.7-4.fc17,nyquist-3.04-4b.fc17.1,jide-oss-2.7.6-6.1340svn.fc17,xmlgraphics-commons-1.4-5.fc17,apache-commons-dbcp-1.4-9.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-03-13 14:33:04 EDT
java-1.5.0-gcj-1.5.0.0-39.fc17, opticalraytracer-2.7-4.fc17, nyquist-3.04-4b.fc17.1, jide-oss-2.7.6-6.1340svn.fc17, xmlgraphics-commons-1.4-5.fc17, apache-commons-dbcp-1.4-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.