Bug 79683 - [RFE] RH8.0 unstable when php is installed
[RFE] RH8.0 unstable when php is installed
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-14 20:20 EST by redhatbug
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-08 11:54:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhatbug 2002-12-14 20:20:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
This is a request for an enhancement to solve a serious unstable problem.  I 
was told when I contacted Red Hat to post this issue here with [RFE] at the 
start of the summary.

Have the ability to install PHP with Apache 1.3 instead of Apache 2.0.  RedHat 
8.0 only gives the option to install Apache 2.0, however PHP does not run 
stably yet on Apache 2.0 and the php.net developers still are strongly are 
suggesting that you do not use Apache 2.0 with PHP in a production environment.

I'd like to upgrade my servers to the newer RH8.0 version to take advantage of 
some other improvements but because most of my servers use PHP in production 
environments I can not risk my business by putting an unstable setup of PHP in 
place.

Please consider adding this to the RedHat network so I can install a stable 
http/php server on RedHat 8.0

I know that Apache 2.0 is not considered unstable anymore on it's own so it'd 
be great to have the option to put Apache 2.0 or 1.3 that way my production 
sites can still have the stable 1.3/php combination.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.This is a request for enhancement to solve a non-production quality setup 
you have with PHP (it's the fact php installs with Apache 2.0 in which php 
does not run stable enough yet for a production/business environment
    

Additional info:
Comment 1 Cristian Gafton 2002-12-17 15:15:05 EST
Assign to the right product. Fix priority.
Comment 2 Joe Orton 2002-12-17 16:19:50 EST
Hi - just to clarify, this is something you have actually experienced, i.e. you
are seeing server crashes when using PHP in 8.0?  If so, these are obviously
things we will fix, but some more details would be useful (e.g. which extension
modules are in use)

Comment 3 Joe Orton 2003-06-13 07:18:36 EDT
If no details are given about instability problems we cannot fix them; please
file bugs on reproducible problems.
Comment 4 redhatbug 2003-06-13 12:20:06 EDT
I don't have those anymore as I moved back to RH 7.3 - basically there was 
problems with sessions and memory leaks.

Perhaps you need to contact the actual developers of PHP.  

This is more a poor business choice than a bug as your are installing an alpha 
quality program on a server and labling it as stable.

I don't see how you can install a product (php) on your servers and call your 
servers stable if the developers themselves say their product is unstable when 
installed with apache 2.x.  It even gives this warning NOT TO USE on 
production servers when you compile it with apache 2.x
Comment 5 Joe Orton 2003-07-08 11:54:36 EDT
The warning in the PHP documentation is really inspired by the problems which
you'd find if using PHP with one of the thread-based server models in Apache
httpd 2.0.  The default httpd binary we provide uses the same "prefork" model
(process-based not thread-based) as in 1.3, so this is not a cause for concern.

I'm going to close this bug as there is nothing we will fix here.  Thanks for
your feedback.

Note You need to log in before you can comment on or make changes to this bug.