Bug 79684 - Unable to mount USB cdrom burner
Unable to mount USB cdrom burner
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-14 20:24 EST by Steve Bangert
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-03 14:10:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg with USB storage debug enabled (2.82 KB, text/plain)
2002-12-14 20:34 EST, Steve Bangert
no flags Details
patch transport.c and .h (14.54 KB, patch)
2002-12-14 20:42 EST, Steve Bangert
no flags Details | Diff
usb storage patch (1.45 KB, patch)
2003-03-06 05:58 EST, Steve Bangert
no flags Details | Diff

  None (edit)
Description Steve Bangert 2002-12-14 20:24:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.20-rmap15b i586)

Description of problem:
I've got a Sony Spressa cdrom burner model #CRX100E/X that worked fine under
RH-7.1 and RH-7.2 (except for a problem with the scsi-cdrom module failing to
load on boot about two thirds of the time, which required another reboot or two
until the module would finally load) on RH-7.3 and RH-8.0 I am unable to mount
the device and just get
an error " unable to mount device, bad super block, etc,etc" and when using
Xcdroast it fails to recognize any media. I have traced the problem to version
1.44 of transport.c that was first introduced in kernel 2.4.19-pre3 and then
backported to the RH-2.4.18.xxx kernels. All vanilla kernels 2.4.19-pre2 and
older work fine!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.plug-in cdrom, turn it on
2.boot RH-7.3
3.try to mount USB CDROM
    

Actual Results:  unable to mount USB cdrom

Expected Results:  should be able to mount device, Xcdroast shpould be able to
recognize cdrom media

Additional info:

problem started with version 1.44 of transport.c or 1.17 of transport.h
Comment 1 Steve Bangert 2002-12-14 20:34:07 EST
Created attachment 88737 [details]
output of dmesg with USB storage debug enabled
Comment 2 Steve Bangert 2002-12-14 20:42:20 EST
Created attachment 88738 [details]
patch transport.c and .h

this is the patch(s) that broke USB storage for me
Comment 3 Steve Bangert 2003-03-06 05:59:00 EST
Created attachment 90488 [details]
usb storage patch
Comment 4 Steve Bangert 2003-03-06 06:04:18 EST
Thanks to Alan Stern this matter is solved, see the latest attachment, is there
any chance that this patch could be applied to the latest beta (pheobe) kernel
before RH8.1 is released, this patch should help a lot of people.
Comment 5 Pete Zaitcev 2003-06-03 14:10:24 EDT
2.4.20-18(.[789]) is available today.

Note You need to log in before you can comment on or make changes to this bug.