Bug 796904 - unable to change screen brightness after suspend on Thinkpad W520
unable to change screen brightness after suspend on Thinkpad W520
Status: CLOSED DUPLICATE of bug 808942
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 15:43 EST by patrick korsnick
Modified: 2012-04-01 18:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-01 18:24:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description patrick korsnick 2012-02-23 15:43:25 EST
Description of problem:

f16 Gnome on thinkpad w520 running in descrete graphics mode (with noapic kernel flag) nouveau driver

initially i was able to use the fn + Brightness up/dn keys to change screen brightness but somewhere along the way it stopped working.

a google search said to try 'yum reinstall bash' and that fixed the problem for a while, but now it is broken again and trying to reinstall bash doesn't fix the problem.

tried using the GUI in System Settings->Screen but that doesn't work either

this functionality works fine on my f16 KDE and Xfce installs on same machine

Version-Release number of selected component (if applicable):


How reproducible:

every time

Steps to Reproduce:
1. try to adjust screen brightness via keyboard or GUI
2.
3.
  
Actual results:

no brightness change
Expected results:
brightness to change

Additional info:
Comment 1 patrick korsnick 2012-02-24 00:24:45 EST
correction: I was actually able to reproduce this problem on my f16 KDE and Xfce installs on the same machine- I was unable to adjust screen brightness. So it doesn't work on any f16 install on this machine.
Comment 2 patrick korsnick 2012-04-01 18:03:06 EDT
Additional info:

On f16 and f17 running the newest yum updated 3.3.0-X kernels I can change screen brightness _until_ i suspend the machine. After having suspended the machine the brightness controls do nothing. Screen is set at maximum brightness. This behavior happens on the GNOME, XFCE and KDE spins.
Comment 3 patrick korsnick 2012-04-01 18:24:51 EDT

*** This bug has been marked as a duplicate of bug 808942 ***

Note You need to log in before you can comment on or make changes to this bug.