This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 797015 - [virt-viewer] Virt-viewer doesn't start with specific locales.
[virt-viewer] Virt-viewer doesn't start with specific locales.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Ankit Patel
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 22:21 EST by Geyang Kong
Modified: 2016-04-26 12:03 EDT (History)
8 users (show)

See Also:
Fixed In Version: virt-viewer-0.5.2-2.el6
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:11:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot on CN locale (1.10 MB, image/png)
2012-02-23 22:22 EST, Geyang Kong
no flags Details
Screenshot on EN locale (1.05 MB, image/png)
2012-02-23 22:29 EST, Geyang Kong
no flags Details
Screenshot on JP locale (1.07 MB, image/png)
2012-02-23 22:31 EST, Geyang Kong
no flags Details
virt-viewer debuginfo (57.70 KB, text/plain)
2012-02-23 22:31 EST, Geyang Kong
no flags Details

  None (edit)
Description Geyang Kong 2012-02-23 22:21:08 EST
Description of problem:
  Virt-viewer doesn't start with specific locales.

Version-Release number of selected component (if applicable):
libvirt-0.9.10-1.el6.x86_64
python-virtinst-0.600.0-7.el6.noarch
qemu-kvm-0.12.1.2-2.229.el6.x86_64
virt-manager-0.9.0-10.el6.x86_64
Linux version 2.6.32-220.el6.x86_64
virt-viewer-0.5.1-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:

1. Make sure virt-viewer-0.5.1-1.el6.x86_64 installed.

2. Make sure there is a guest running on the host.

3. Type following command in terminal: #dom=<guest name>

4. Type following command in terminal: #for i in en_US ko_KR ja_JP zh_CN zh_TW pt_BR de_DE es_ES fr_FR it_IT ru_RU as_IN bn_IN gu_IN hi_IN kn_IN ml_IN mr_IN or_IN pa_IN ta_IN te_IN si_LK ; do echo "Starting virt-viewer with locale of "$i; export LANG=$i.UTF-8; virt-viewer $dom && echo;  done

Actual results:

1. Words in menus did not change with the locales except ja_JP.(Please refer to screenshots in attachments)

2. Some strange strings appeared on the title bar of the virt-viewer form.(Please refer to screenshots in attachments)

Expected results:

1. Words in menus could change with the locales.

2. Contents in title bar could be displayed normally.

Additional info:

1. This issue cannot be reproduced on virt-viewer-0.4.1-7.el6.x86_64.
Comment 2 Geyang Kong 2012-02-23 22:22:06 EST
Created attachment 565470 [details]
Screenshot on CN locale
Comment 3 Geyang Kong 2012-02-23 22:29:50 EST
Created attachment 565471 [details]
Screenshot on EN locale
Comment 4 Geyang Kong 2012-02-23 22:31:00 EST
Created attachment 565476 [details]
Screenshot on JP locale
Comment 5 Geyang Kong 2012-02-23 22:31:36 EST
Created attachment 565479 [details]
virt-viewer debuginfo
Comment 8 Ankit Patel 2012-02-28 23:45:01 EST
Hi Daniel,

We are already part of the Fedora upstream (where transifex is hosting translations) community. So we should be able to do it.

When do you need it to be done?

Thanks!
Ankit
Comment 11 Daniel Berrange 2012-03-09 12:01:01 EST
I have pull in updated translations from transifex for the following locales:

as.po  bn_IN.po  de.po  fr.po  he.po  hu.po  ja.po  ko.po  mr.po  or.po  pl.po     pt.po  ta.po  tr.po  zh_CN.po
bg.po  cs.po     es.po  gu.po  hi.po  it.po  kn.po  ml.po  nl.po  pa.po  pt_BR.po  ru.po  te.po  uk.po  zh_TW.po

I don't know if this covers all the ones required for RHEL. If not please put this bug back to ASSIGNED
Comment 14 Geyang Kong 2012-03-12 21:56:45 EDT
Verified pass on build:
virt-viewer-0.5.2-1.el6.x86_64
so change this bug to verified.
Comment 15 Ankit Patel 2012-03-13 01:07:31 EDT
(In reply to comment #11)
> I have pull in updated translations from transifex for the following locales:
> 
> as.po  bn_IN.po  de.po  fr.po  he.po  hu.po  ja.po  ko.po  mr.po  or.po  pl.po 
>    pt.po  ta.po  tr.po  zh_CN.po
> bg.po  cs.po     es.po  gu.po  hi.po  it.po  kn.po  ml.po  nl.po  pa.po 
> pt_BR.po  ru.po  te.po  uk.po  zh_TW.po
> 
> I don't know if this covers all the ones required for RHEL. If not please put
> this bug back to ASSIGNED

Hi,

We were able to submit translations by today itself, as there were some community process delaying the translation submission.

If you can pull the latest translations and make a new build again, it should fix all Red Hat supported languages.

https://fedora.transifex.net/projects/p/virt-viewer/resource/virt-viewerpot/

Re-assigning back to the owner or the component.

Thanks!
Ankit
Comment 16 Daniel Berrange 2012-03-14 13:34:26 EDT
I have updated with latest translations.
Comment 17 Geyang Kong 2012-03-15 02:33:19 EDT
I‘ve checked the link in comment 15 and updated the command to the following:

for i in pl_PL en_US ml_IN as_IN ja_JP fr_FR it_IT zh_CN zh_TW es_ES pt_BR ko_KR ru_RU de_DE bn_IN ta_IN pa_IN hi_IN kn_IN te_IN gu_IN mr_IN or_IN uk_UA ;  do echo "Starting virt-viewer with locale of "$i; export LANG=$i.UTF-8; virt-viewer $dom && echo;  done

But I got something confused me. In some locales, "virt viewer" was left as same as EN, but in some locales, it was translated, and in some other locales, the word "viewer" was translated while word "virt" left as EN.
And this also happened on some menu options. Such as "Sendkey->PrintScreen". Is this all right?
Comment 18 Ankit Patel 2012-03-15 03:41:17 EDT
(In reply to comment #17)
> I‘ve checked the link in comment 15 and updated the command to the following:
> 
> for i in pl_PL en_US ml_IN as_IN ja_JP fr_FR it_IT zh_CN zh_TW es_ES pt_BR
> ko_KR ru_RU de_DE bn_IN ta_IN pa_IN hi_IN kn_IN te_IN gu_IN mr_IN or_IN uk_UA ;
>  do echo "Starting virt-viewer with locale of "$i; export LANG=$i.UTF-8;
> virt-viewer $dom && echo;  done
> 
> But I got something confused me. In some locales, "virt viewer" was left as
> same as EN, but in some locales, it was translated, and in some other locales,
> the word "viewer" was translated while word "virt" left as EN.
> And this also happened on some menu options. Such as "Sendkey->PrintScreen". Is
> this all right?

That should be alright, as we deliberately keep some messages in English itself for better messaging. However, you might want to open new bugs against respective languages where you find messages in English itself. But this bug should not be affected, as the requirement for this bug is to get the 100% translation for Red Hat supported languages.

FYI: Language Support Criteria for RHEL6: https://engineering.redhat.com/trac/LocalizationServices/wiki/L10nRHEL6LanguageSupportCriteria

Thanks!
Ankit
Comment 19 Geyang Kong 2012-03-15 04:14:29 EDT
Verified pass with the packages:

virt-viewer-0.5.2-2.el6.x86_64

Test steps:

1. Make sure virt-viewer-0.5.2-2.el6.x86_64 installed.

2. Make sure there is a guest running on the host.

3. Type following command in terminal: #dom=<guest name>

4. Type following command in terminal: #for i in pl_PL en_US ml_IN as_IN ja_JP fr_FR it_IT zh_CN zh_TW es_ES pt_BR ko_KR ru_RU de_DE bn_IN ta_IN pa_IN hi_IN kn_IN te_IN gu_IN mr_IN or_IN uk_UA ; do echo "Starting virt-viewer with locale of "$i; export LANG=$i.UTF-8;virt-viewer $dom && echo;  done

Test results:

current command works well.

And change this bug to VERIFIED
Comment 20 Daniel Berrange 2012-04-17 06:00:20 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed
Comment 22 errata-xmlrpc 2012-06-20 08:11:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0772.html

Note You need to log in before you can comment on or make changes to this bug.