Bug 797060 - nfs-nlm:nfs server panic
nfs-nlm:nfs server panic
Status: CLOSED DUPLICATE of bug 808390
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Rajesh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-24 01:55 EST by Saurabh
Modified: 2016-01-19 01:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 06:08:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core file (125 bytes, application/x-bzip)
2012-02-24 03:49 EST, Saurabh
no flags Details

  None (edit)
Description Saurabh 2012-02-24 01:55:58 EST
Description of problem:

rpc-coverage test was hung for rpc-fops test

and the core generated is with this backtrace,

(gdb) bt
#0  0x00007f6d71dd2252 in nsm_monitor (host=0x244d040 "RHSSA1") at nlm4.c:478
#1  0x00007f6d71dd34b7 in nlm4_establish_callback (csarg=0x7f6d702608b4) at nlm4.c:836
#2  0x00000034242077e1 in start_thread () from /lib64/libpthread.so.0
#3  0x0000003423ae577d in clone () from /lib64/libc.so.6
(gdb) 



Version-Release number of selected component (if applicable):

[root@RHSSA1 ~]# /root/330/inst/sbin/glusterfs -V
glusterfs 3.3.0qa24 built on Feb 24 2012 04:52:12
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.

How reproducible:


Steps to Reproduce:
1.install 330qa24
2. mount the volume without "nolock" option
3.start rpc-coverage test
  
Actual results:
The test should fails, while generating core

Expected results:
It should pass

Additional info:

logs from nfs.log,

[2012-02-24 04:55:57.083094] W [client.c:1990:client_rpc_notify] 0-dist-rep-client-2: Cancelling the grace timer
[2012-02-24 04:55:57.083205] I [client-handshake.c:1544:select_server_supported_programs] 0-dist-rep-client-2: Using Program GlusterFS 3.3.0qa24, Num (1298437), Version (330)
[2012-02-24 04:55:57.083388] I [client-handshake.c:1324:client_setvolume_cbk] 0-dist-rep-client-2: clnt-lk-version = 1, server-lk-version = 0
[2012-02-24 04:55:57.083405] I [client-handshake.c:1350:client_setvolume_cbk] 0-dist-rep-client-2: Connected to 10.1.11.157:24010, attached to remote volume '/export-xfs/ddr'.
[2012-02-24 04:55:57.083444] I [afr-common.c:3461:afr_notify] 0-dist-rep-replicate-1: Subvolume 'dist-rep-client-2' came back up; going online.
[2012-02-24 04:55:57.086315] W [client.c:1990:client_rpc_notify] 0-dist-rep-client-1: Cancelling the grace timer
[2012-02-24 04:55:57.086599] I [client-handshake.c:1544:select_server_supported_programs] 0-dist-rep-client-1: Using Program GlusterFS 3.3.0qa24, Num (1298437), Version (330)
[2012-02-24 04:55:57.086977] I [client-handshake.c:1324:client_setvolume_cbk] 0-dist-rep-client-1: clnt-lk-version = 1, server-lk-version = 0
[2012-02-24 04:55:57.086997] I [client-handshake.c:1350:client_setvolume_cbk] 0-dist-rep-client-1: Connected to 10.1.11.158:24009, attached to remote volume '/export-xfs/drr'.
[2012-02-24 04:55:58.089146] W [client.c:1990:client_rpc_notify] 0-dist-rep-client-3: Cancelling the grace timer
[2012-02-24 04:55:58.089459] I [client-handshake.c:1544:select_server_supported_programs] 0-dist-rep-client-3: Using Program GlusterFS 3.3.0qa24, Num (1298437), Version (330)
[2012-02-24 04:55:58.089867] I [client-handshake.c:1324:client_setvolume_cbk] 0-dist-rep-client-3: clnt-lk-version = 1, server-lk-version = 0
[2012-02-24 04:55:58.089891] I [client-handshake.c:1350:client_setvolume_cbk] 0-dist-rep-client-3: Connected to 10.1.11.158:24010, attached to remote volume '/export-xfs/ddrr'.
[2012-02-24 04:57:23.230324] I [afr-common.c:1827:afr_set_root_inode_on_first_lookup] 0-dist-rep-replicate-1: added root inode
[2012-02-24 04:57:23.232143] W [rpcsvc.c:175:rpcsvc_program_actor] 0-rpc-service: RPC program not available (req 100227 3)
[2012-02-24 04:57:23.232437] W [rpcsvc.c:1111:rpcsvc_error_reply] (-->/root/330/inst/lib/libgfrpc.so.0(rpc_transport_notify+0x130) [0x7f6d76260db8] (-->/root/330/inst/lib/libgfrpc.so.0(rpcsvc_notify+0x181) [0x7f6d7625b45c] (-->/root/330/inst/lib/libgfrpc.so.0(rpcsvc_handle_rpc_call+0x37b) [0x7f6d7625b0d4]))) 0-: sending a RPC error reply
[2012-02-24 04:59:43.952480] E [nlm4.c:455:nsm_monitor] 0-nfs-NLM: Clnt_create()
pending frames:

patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2012-02-24 04:59:43
configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.3.0qa24
/lib64/libc.so.6[0x3423a32980]
/root/330/inst/lib/glusterfs/3.3.0qa24/xlator/nfs/server.so(nsm_monitor+0x229)[0x7f6d71dd2252]
/root/330/inst/lib/glusterfs/3.3.0qa24/xlator/nfs/server.so(nlm4_establish_callback+0x7a)[0x7f6d71dd34b7]
/lib64/libpthread.so.0[0x34242077e1]
/lib64/libc.so.6(clone+0x6d)[0x3423ae577d]
---------
Comment 1 Saurabh 2012-02-24 03:49:28 EST
Created attachment 565536 [details]
core file

core is attached
Comment 2 Vijay Bellur 2012-04-02 06:08:47 EDT

*** This bug has been marked as a duplicate of bug 808390 ***

Note You need to log in before you can comment on or make changes to this bug.