Bug 79708 - console is not properly cleared with "bad" characters
console is not properly cleared with "bad" characters
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
David Lawrence
http://www.movement.uklinux.net/dropp...
:
: 80031 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-15 19:43 EST by John Levon
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:30:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Levon 2002-12-15 19:43:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Using KDE konsole in RH8.0, when the console is cleared
with "clear", after e.g. catting a binary file, the screen
is not cleared properly - there are droppings visible.

This is also seen when ssh'ing and running mutt remotely -
the purple arrows are left behind - an example is seen
in the screen shot at the URL.

Another example is :

http://www.movement.uklinux.net/droppings2.png

This is perhaps related to the fact that e.g. "man ls" cannot
display a dash ('-') - it comes out as a box. I am using
the default font for konsole from the distribution.

Note that hiding/unhiding the window or switching workspaces
clears it. I'm using the Riva 128 X driver.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.load up konsole 
2.cat /bin/ls
3.press return several times, observe droppings
    

Actual Results:  Droppings left on screen

Expected Results:  No droppings...

Additional info:
Comment 1 Mike A. Harris 2002-12-17 14:42:32 EST
Sounds like a KDE issue, not an XFree86 one.

There's no driver called "Riva 128". An Nvidia Riva 128 card uses
the "nv" driver.  Or else you have an ATI Rage 128, and might be
confusing Rage with Riva, this is the r128 driver.
Comment 2 John Levon 2002-12-17 15:38:12 EST
Sorry, typo. I indeed meant Rage 128 (r128 driver).

btw, changing LANG does not change anything.
Comment 3 Ngo Than 2002-12-18 16:00:30 EST
it seems that konsole cannot work well with monospace font at the moment.
A workaround to this problem, you should change the font to Lucidatywriter font
or Fixed font. It should work fine.


Comment 4 John Levon 2002-12-18 17:10:08 EST
I'm afraid not. Using Lucida typewriter, the cat /bin/ls behaviour
is still present.

However, Lucida does appear to fix the problem with the purple
thread arrows in my mutt session I mentioned.
Comment 5 Ngo Than 2002-12-20 11:22:43 EST
*** Bug 80031 has been marked as a duplicate of this bug. ***
Comment 6 Fernando Perez 2002-12-27 21:32:17 EST
I solved this by changing the system default locale back to regular non-utf-8. Edit /etc/sysconfig/i18n and change it to:

LANG="en_US"
SUPPORTED="en_US.UTF-8:en_US:en:es_CO.UTF-8:es_CO:es"
SYSFONT="iso01.16"

(in SUPPORTED add whatever you want). The point is that LANG should NOT be a utf-8 locale. It's great that RedHat wants to move to utf-8 system-wide, but it obviously doesn't work too well yet. The above will give you clean-looking terminals with any font (in konsole) and will also solve the issue with broken dashes in man and pinfo (btw, 'pinfo -csm' makes for a far better 'man').

I'll be glad to switch to full utf-8, when it actually doesn't break half the system (including such basic things as terminal windows and man pages!)
Comment 7 John Levon 2002-12-29 13:39:27 EST
I cannot confirm this workaround.

LANG="en_GB"
SUPPORTED="en_GB.UTF-8:en_GB:en:pl_PL.UTF-8:pl_PL:pl:ru_RU.UTF-8:ru_RU:ru"
#SYSFONT="latarcyrheb-sun16"
SYSFONT="iso01.16"

Manpages are readable now, obviously, but konsole can no longer display
Cyrillic_zhe etc. In any case, both the "cat /bin/ls" and the mutt problems
are still evident.

What reads $SUPPORTED ? It is not exported.
Comment 8 Petr Rockai 2006-07-17 14:36:54 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 9 Bill Nottingham 2006-10-18 14:30:26 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.