Bug 797167 - [88c6c11813cbd60a6b8e5ec4e2edd40e326ac311]: dht reporting gfid different on backend
[88c6c11813cbd60a6b8e5ec4e2edd40e326ac311]: dht reporting gfid different on b...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
pre-release
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: shishir gowda
:
: 786419 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-02-24 07:42 EST by Rahul C S
Modified: 2013-12-08 20:29 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 14:00:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 1f3a0dd4742a2fcd3215aee4a5e22125d7ea4f4d
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
glusterfs logs (36.51 KB, application/x-bzip)
2012-02-24 07:42 EST, Rahul C S
no flags Details
directory structure script (504 bytes, application/x-shellscript)
2012-02-24 07:44 EST, Rahul C S
no flags Details

  None (edit)
Description Rahul C S 2012-02-24 07:42:41 EST
Created attachment 565593 [details]
glusterfs logs

Description of problem:
Create a distributed-replicate volume, mount 2 clients, kill 1 brick.

From both the clients, create a hierarchy of directories with same names[basically run same script], logs report gfid different on backends. Also thinks the directory is a file with these errors on the client:
[dht-common.c:744:dht_lookup_everywhere_done] 0-vol-dht: path /temp/0e/cc exists as a file on one subvolume and directory on another. Please fix it manually
Comment 1 Rahul C S 2012-02-24 07:44:32 EST
Created attachment 565594 [details]
directory structure script

attaching the hierarchical directory structure creation script.
Comment 2 Anand Avati 2012-02-29 05:10:29 EST
CHANGE: http://review.gluster.com/2832 (storage/posix: In lookup check for buf->gfid being NULL) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 Pranith Kumar K 2012-03-01 07:30:36 EST
*** Bug 786419 has been marked as a duplicate of this bug. ***
Comment 4 Rahul C S 2012-04-05 04:01:02 EDT
Not seeing similar logs. Works fine.

Note You need to log in before you can comment on or make changes to this bug.