Bug 797266 - bluez headers fail without -fpermissive
bluez headers fail without -fpermissive
Status: CLOSED DUPLICATE of bug 791292
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-24 12:46 EST by Rex Dieter
Modified: 2012-02-24 13:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-24 13:05:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-02-24 12:46:40 EST
anything that includes /usr/include/bluetooth/bluetooth.h yields gcc-4.7 errors:

In file included from linux/qsysteminfo_linux_common.cpp:73:0:
/usr/include/bluetooth/bluetooth.h: In function ‘uint64_t bt_get_le64(void*)’:
/usr/include/bluetooth/bluetooth.h:131:113: error: invalid conversion from ‘void*’ to ‘bt_get_le64(void*)::<anonymous struct>*’ [-fpermissive]
In file included from linux/qsysteminfo_linux_common.cpp:73:0:
/usr/include/bluetooth/bluetooth.h: In function ‘uint64_t bt_get_be64(void*)’:
/usr/include/bluetooth/bluetooth.h:136:166: error: invalid conversion from ‘void*’ to ‘bt_get_be64(void*)::<anonymous struct>*’ [-fpermissive]
In file included from linux/qsysteminfo_linux_common.cpp:73:0:
/usr/include/bluetooth/bluetooth.h: In function ‘uint32_t bt_get_le32(void*)’:
/usr/include/bluetooth/bluetooth.h:141:113: error: invalid conversion from ‘void*’ to ‘bt_get_le32(void*)::<anonymous struct>*’ [-fpermissive]
In file included from linux/qsysteminfo_linux_common.cpp:73:0:
/usr/include/bluetooth/bluetooth.h: In function ‘uint32_t bt_get_be32(void*)’:
/usr/include/bluetooth/bluetooth.h:146:165: error: invalid conversion from ‘void*’ to ‘bt_get_be32(void*)::<anonymous struct>*’ [-fpermissive]
In file included from linux/qsysteminfo_linux_common.cpp:73:0:
/usr/include/bluetooth/bluetooth.h: In function ‘uint16_t bt_get_le16(void*)’:
/usr/include/bluetooth/bluetooth.h:151:113: error: invalid conversion from ‘void*’ to ‘bt_get_le16(void*)::<anonymous struct>*’ [-fpermissive]
/usr/include/bluetooth/bluetooth.h: In function ‘uint16_t bt_get_be16(void*)’:
/usr/include/bluetooth/bluetooth.h:156:192: error: invalid conversion from ‘void*’ to ‘bt_get_be16(void*)::<anonymous struct>*’ [-fpermissive]
make[2]: *** [../../build/Release/QtSystemInfo/qsysteminfo_linux_common.o] Error 1
Comment 1 Rex Dieter 2012-02-24 13:05:22 EST
re-assigning => bluez
Comment 2 Rex Dieter 2012-02-24 13:05:53 EST

*** This bug has been marked as a duplicate of bug 791292 ***

Note You need to log in before you can comment on or make changes to this bug.