Bug 79727 - Xircom ethernet/modem pcmcia card not fully initialized
Xircom ethernet/modem pcmcia card not fully initialized
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-16 04:51 EST by P Fudd
Modified: 2015-01-04 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 03:27:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Fudd 2002-12-16 04:51:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I'm using a Dell Inspiron 7500, fresh install of RH8.0, with a Xircom RealPort
CardBus Ethernet 10/100+ Modem 56 PCMCIA card.  It's a hand-me-down laptop+card
and used to run windows 98.

I tried using the modem for the first time today, and it didn't work.
That is to say, dmesg reported the serial port being added as /dev/ttyS4, but
running minicom and connecting to that port didn't allow me to type anything; AT
commands didn't work.

I tried running '/etc/pcmcia/serial start ttyS4', but it gave me a usage
message, with no error to go with it.  (fix this?)

After looking at /etc/pcmcia/serial and /etc/pcmcia/shared, I discovered that
the scripts were looking at /var/lib/pcmcia/stab for the possible devices.  The
contents of the file didn't match the format that 'get_info' in 'shared' was
looking for, which is why the 'serial' script gave me a usage message.

I created an entry in the 'stab' file, and then 'serial start ttyS4' worked. 
Here's my entry in /var/lib/pcmcia/stab:
  0 serial serial foo ttyS4 4 68
(I guessed at the 'serial serial foo' bits)

Now when I run /etc/pcmcia/serial start ttyS4, it doesn't complain, and the
modem responds to 'AT' commands.

However, when I pull out or insert the card, the stab file is rewritten to its
original contents and my changes are lost:

Card in:
  Socket 0: Cardbus hotplug device
  Socket 1: empty

Card out:
  Socket 0: empty
  Socket 1: empty

Offhand, I'd say that cardmgr is writing the wrong data to /var/lib/pcmcia/stab.
 Maybe my card is just not supported fully by the cardmgr program.  Also, I
don't know when the '/etc/pcmcia/serial' script is supposed to run, is that
called by cardmgr or by hotplug?

After all that tinkering, all 'serial start ttyS4' does is run 'setserial' twice
in order to fix a glitch in the pcmcia chipset, which solved my problem.

Version-Release number of selected component (if applicable):
kernel-pcmcia-cs-3.1.31-9

How reproducible:
Sometimes

Steps to Reproduce:
1. Insert this Xircom combo card
2. Run minicom, using serial port /dev/ttyS4
3. Type 'at<enter>'
    

Actual Results:  Modem doesn't show keystrokes, doesn't say 'ok'.

Expected Results:  It should have said 'ok'.  When '/var/lib/pcmcia/stab is
fixed', and '/etc/pcmcia/serial start ttyS4' is run, the modem starts working,
and keeps working even after a reboot and powercycle.  Hard to repeat the test.
 Maybe running windows will change the card settings, allowing a person to show
the bug again.

Additional info:

# lspci -v
02:00.0 Ethernet controller: Xircom Cardbus Ethernet 10/100 (rev 03)
        Subsystem: Xircom Cardbus Ethernet 10/100
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at 4000 [size=128]
        Memory at 10800000 (32-bit, non-prefetchable) [size=2K]
        Memory at 10800800 (32-bit, non-prefetchable) [size=2K]
        Expansion ROM at 10400000 [size=16K]
        Capabilities: [dc] Power Management version 1

02:00.1 Serial controller: Xircom Cardbus Ethernet + 56k Modem (rev 03) (prog-if
02 [16550])
        Subsystem: Xircom CBEM56G-100 Ethernet + 56k Modem
        Flags: medium devsel, IRQ 11
        I/O ports at 4080 [size=8]
        Memory at 10801000 (32-bit, non-prefetchable) [size=2K]
        Memory at 10801800 (32-bit, non-prefetchable) [size=2K]
        Expansion ROM at 10404000 [size=16K]
        Capabilities: [dc] Power Management version 1

# lspci -n
02:00.0 Class 0200: 115d:0003 (rev 03)
02:00.1 Class 0700: 115d:0103 (rev 03)

Note You need to log in before you can comment on or make changes to this bug.