This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 7973 - Error compiling SSH on Sparc (RedHat 6.1)
Error compiling SSH on Sparc (RedHat 6.1)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
6.1
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-23 12:45 EST by croyston
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 17:43:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description croyston 1999-12-23 12:45:04 EST
I get the following error when trying to compile SSH 1.2.26 or 1.2.27

gcc -pipe  -o ssh ssh.o sshconnect.o log-client.o readconf.o hostfile.o
readpass.o tildexpand.o clientloop.o canohost.o  idea.o rsa.o randoms.o
md5.o buffer.o emulate.o packet.o compress.o xmalloc.o ttymodes.o
newchannels.o bufaux.o authfd.o authfile.o crc32.o rsaglue.o cipher.o des.o
match.o arcfour.o mpaux.o userfile.o signals.o blowfish.o deattack.o  \
	-Lgmp-2.0.2-ssh-2 -lgmp -Lzlib-1.0.4 -lz  -lnsl -lbsd -lcrypt
-L/usr/local/lib  -lutil
gmp-2.0.2-ssh-2/libgmp.a(mpn_divmod_1.o): In function `__mpn_divmod_1':
/tmp/ssh-1.2.26/gmp-2.0.2-ssh-2/mpn/divmod_1.c:91: undefined reference to
`__udiv_qrnnd'
/tmp/ssh-1.2.26/gmp-2.0.2-ssh-2/mpn/divmod_1.c:129: undefined reference to
`__udiv_qrnnd'
/tmp/ssh-1.2.26/gmp-2.0.2-ssh-2/mpn/divmod_1.c:204: undefined reference to
`__udiv_qrnnd'
gmp-2.0.2-ssh-2/libgmp.a(mpn_divrem.o): In function `__mpn_divrem':
/tmp/ssh-1.2.26/gmp-2.0.2-ssh-2/mpn/divrem.c:84: undefined reference to
`__udiv_qrnnd'
/tmp/ssh-1.2.26/gmp-2.0.2-ssh-2/mpn/divrem.c:88: undefined reference to
`__udiv_qrnnd'
gmp-2.0.2-ssh-2/libgmp.a(mpn_divrem.o):/tmp/ssh-1.2.26/gmp-2.0.2-ssh-2/mpn/divrem.c:141:
more undefined references to `__udiv_qrnnd' follow
collect2: ld returned 1 exit status
make: *** [ssh] Error 1


I am compiling on a SUN Ultra 170

{croyston@dhcp31-39.level1.com:41} gcc -v
Reading specs from /usr/lib/gcc-lib/sparc-redhat-linux/egcs-2.91.66/specs
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)
Comment 1 Jim Kingdon 1999-12-23 14:50:59 EST
This would appear to be a bug in GCC and/or the libraries, but tracking
it down may take a bit of effort.  Could you send a self-contained test
case?  Sounds like it would be the output of "gcc -E"
for one of the source files which is causing the problem
( gmp-2.0.2-ssh-2/mpn/divmod_1.c it would appear).
Comment 2 Cristian Gafton 2000-02-17 17:43:59 EST
closed because of lack of feedback

Note You need to log in before you can comment on or make changes to this bug.