Bug 797401 - SELinux is preventing /usr/lib/virtualbox/VirtualBox from using the 'setuid' capabilities.
SELinux is preventing /usr/lib/virtualbox/VirtualBox from using the 'setuid' ...
Status: CLOSED DUPLICATE of bug 796935
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:93f150f9d2494e63d0429f2c994...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-25 10:42 EST by Pascal94
Modified: 2012-02-27 04:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-27 04:08:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pascal94 2012-02-25 10:42:20 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.7-1.fc16.x86_64
reason:         SELinux is preventing /usr/lib/virtualbox/VirtualBox from using the 'setuid' capabilities.
time:           sam. 25 févr. 2012 16:42:05 CET

description:
:SELinux is preventing /usr/lib/virtualbox/VirtualBox from using the 'setuid' capabilities.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that VirtualBox should have the setuid capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep VirtualBox /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:boinc_project_t:s0
:Target Context                system_u:system_r:boinc_project_t:s0
:Target Objects                 [ capability ]
:Source                        VirtualBox
:Source Path                   /usr/lib/virtualbox/VirtualBox
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           VirtualBox-4.1-4.1.8_75467_fedora16-1.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux CM-ELITE-341 3.2.7-1.fc16.x86_64 #1 SMP Tue
:                              Feb 21 01:40:47 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    jeu. 23 févr. 2012 20:18:45 CET
:Last Seen                     jeu. 23 févr. 2012 20:18:45 CET
:Local ID                      acd7532c-b770-4ac3-b32f-37ea201e7e05
:
:Raw Audit Messages
:type=AVC msg=audit(1330024725.721:200): avc:  denied  { setuid } for  pid=5921 comm="VirtualBox" capability=7  scontext=system_u:system_r:boinc_project_t:s0 tcontext=system_u:system_r:boinc_project_t:s0 tclass=capability
:
:
:type=SYSCALL msg=audit(1330024725.721:200): arch=x86_64 syscall=setresuid success=yes exit=0 a0=3e1 a1=3e1 a2=3e1 a3=0 items=0 ppid=5748 pid=5921 auid=4294967295 uid=993 gid=990 euid=993 suid=993 fsuid=993 egid=990 sgid=990 fsgid=990 tty=(none) ses=4294967295 comm=VirtualBox exe=/usr/lib/virtualbox/VirtualBox subj=system_u:system_r:boinc_project_t:s0 key=(null)
:
:Hash: VirtualBox,boinc_project_t,boinc_project_t,capability,setuid
:
:audit2allow
:
:#============= boinc_project_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow boinc_project_t self:capability setuid;
:
:audit2allow -R
:
:#============= boinc_project_t ==============
:#!!!! This avc is allowed in the current policy
:
:allow boinc_project_t self:capability setuid;
:
Comment 1 Miroslav Grepl 2012-02-27 04:08:06 EST

*** This bug has been marked as a duplicate of bug 796935 ***

Note You need to log in before you can comment on or make changes to this bug.