Bug 79744 - help browser popups on "grep"
help browser popups on "grep"
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Depends On:
  Show dependency treegraph
Reported: 2002-12-16 09:57 EST by Lars Jonsson
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-04-13 23:49:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lars Jonsson 2002-12-16 09:57:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
the help browser (yelp) popup when I type "gre" fast on the terminal.
Can't explain why? and its really anonying!

somehow it seems that the string "gre" is connected to the F1 button?
I have this problem on every gnome app.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.open up a gnome-terminal
2.type "gre" fast.

Actual Results:  help browser pops up

Expected Results:  nothing

Additional info:
Comment 1 Havoc Pennington 2002-12-16 13:49:48 EST
There is just no way. ;-) 

Do you have a laptop where the function keys are alternates on the main keys 
for example?

Maybe you somehow changed the keybinding for help in
gnome-terminal->Edit->Keybindings so it isn't F1 anymore?
Comment 2 Lars Jonsson 2002-12-17 03:15:18 EST
Yeah, I have a laptop.. compaq evo n600c
and now I have disabled the F1 button for the help browser.

and now when I type "gre" it adds "p" and I get a beep through the speaker?!

It´s really strange! Im going mad!

Observe!, Its in every gnome app. not just the gnome-terminal.. but not in 
anything else..
maybe something with "stty" or something?

I ran redhat 7.3 before without problem.. I got this prob. when upgrading to 

[wmdljo@xxxxx wmdljo]$ grep grepp grpep grep grpep grpep grep
[wmdljo@xxxxx wmdljo]$ stty -a
speed 38400 baud; rows 24; columns 80; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>;
eol2 = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff
-iuclc -ixany -imaxbel
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt
echoctl echoke

Comment 3 Lars Jonsson 2002-12-17 04:58:02 EST
I´ve fixed it!
If I enabled the "Bounce keys" and set the value to 10 msec this strange 
problem stopped buggin me. I Dont really know what it does, but now it works?!
I guess its just a workaround.. Or I have some strange keyboard error..?!

Comment 4 Havoc Pennington 2002-12-17 13:31:52 EST
It's quite possible you had just turned on some of the accessibility features.
Those do cause some funky keyboard behavior if you aren't expecting it.

Note You need to log in before you can comment on or make changes to this bug.