Bug 797504 - [abrt] ibus-1.4.1-1.fc16: __GI_raise: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] ibus-1.4.1-1.fc16: __GI_raise: Process /usr/bin/ibus-daemon was killed...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:df2dca631549b937bebbe0813f8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-26 04:28 EST by rita.heinrich
Modified: 2012-02-29 22:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 22:20:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (8.13 KB, text/plain)
2012-02-26 04:28 EST, rita.heinrich
no flags Details
File: backtrace (11.67 KB, text/plain)
2012-02-26 04:28 EST, rita.heinrich
no flags Details

  None (edit)
Description rita.heinrich 2012-02-26 04:28:30 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon -r --xim
crash_function: __GI_raise
executable:     /usr/bin/ibus-daemon
kernel:         3.2.6-3.fc16.x86_64
pid:            2258
pwd:            /tmp
reason:         Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
time:           Di 21 Feb 2012 17:46:30 CET
uid:            1000
username:       rita
var_log_messages: Feb 21 17:46:30 linux abrt[2710]: Saved core dump of pid 2258 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2012-02-21-17:46:30-2258 (27439104 bytes)

backtrace:      Text file, 11954 bytes
maps:           Text file, 8324 bytes

build_ids:
:e2e67b3ae2579e1667b73ad385f61552931024e9
:4b4285058f7f6b39b7e7c45df83fd36c6833bfe4
:3269336f76283d9cebaa8222e0017c80fd14bdf6
:638db099ff5fb986d1a092629d1bb1dca5be4904
:c124e79ca47fee27b34b962e8144fd5ae98f1dae
:3ed9e61c2b7e707ce244816335776afa2ad0307d
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:e5429e0905bedecc534b057783916ba43e06a66e
:374add1ead31ccb449779bc7ee7877de3377e5ad
:2976a5f82b01d5dedaaefdd41fa7a78b090c75a1
:ee2f04900ae1f07517d91eba300ef385fccab1b8
:ab59942678bcdecb23756804dcd0aac63ccc1669
:c6219cb553f3caadd654b9605013465b8789b519
:58f626f3815dd6adeb4a543bca2472ab98f2953b
:56cd5a4b8ecf7f375c95a4fd575895efbe294071
:0fe03f2aa418c7dbfdc2d0d1802a8e86b27d3120
:32043a4ded0564b5068ef09128c7644695a3963b

dso_list:
:/lib64/libdl-2.14.90.so glibc-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425323
:/usr/lib64/libibus-1.0.so.0.401.0 ibus-libs-1.4.1-1.fc16.x86_64 (Fedora Project) 1329809684
:/lib64/libpthread-2.14.90.so glibc-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425323
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425323
:/lib64/libgthread-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.x86_64 (Fedora Project) 1327404550
:/usr/lib64/gconv/gconv-modules.cache glibc-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425323
:/lib64/libglib-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.x86_64 (Fedora Project) 1327404550
:/lib64/libc-2.14.90.so glibc-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425323
:/lib64/libgio-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.x86_64 (Fedora Project) 1327404550
:/lib64/librt-2.14.90.so glibc-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425323
:/lib64/libgobject-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.x86_64 (Fedora Project) 1327404550
:/lib64/libresolv-2.14.90.so glibc-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425323
:/lib64/libgmodule-2.0.so.0.3000.2 glib2-2.30.2-1.fc16.x86_64 (Fedora Project) 1327404550
:/usr/lib64/libffi.so.5.0.10 libffi-3.0.10-1.fc16.x86_64 (Fedora Project) 1320287345
:/usr/share/locale/de/LC_MESSAGES/libc.mo glibc-common-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425319
:/usr/share/locale/de/LC_MESSAGES/glib20.mo glib2-2.30.2-1.fc16.x86_64 (Fedora Project) 1327404550
:/usr/share/locale/de/LC_MESSAGES/glib20.mo glib2-2.30.2-1.fc16.i686 (Fedora Project) 1327404885
:/usr/bin/ibus-daemon ibus-1.4.1-1.fc16.x86_64 (Fedora Project) 1329809698
:/lib64/libselinux.so.1 libselinux-2.1.6-6.fc16.x86_64 (Fedora Project) 1329609294
:/lib64/libz.so.1.2.5 zlib-1.2.5-6.fc16.x86_64 (Fedora Project) 1326879216
:/usr/lib/locale/locale-archive glibc-common-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425319
:/lib64/ld-2.14.90.so glibc-2.14.90-24.fc16.4.x86_64 (Fedora Project) 1325425323

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-LApIine3YG,guid=39f705284a964393439cccc500000061
:PREFERRED=/usr/bin/startlxde
:XDG_SESSION_COOKIE=2679a5a810351ca82a2526af0000000a-1329842264.206373-829737347
:XDG_RUNTIME_DIR=/run/user/rita
:DISPLAY=:0
:DESKTOP_SESSION=/usr/bin/startlxde
:LC_MESSAGES=de_DE.UTF-8
:PATH=/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin
:XDG_VTNR=1
:LANGUAGE=de_DE.UTF-8
:XDG_SESSION_ID=1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-LApIine3YG,guid=39f705284a964393439cccc500000061
:XDG_SEAT=seat0
:XAUTHORITY=/home/rita/.Xauthority
:USER=rita
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1579
:SYSFONT=latarcyrheb-sun16
:SHLVL=1
:PWD=/home/rita
:BOOT_IMAGE=/vmlinuz-3.2.6-3.fc16.x86_64
:GNOME_KEYRING_CONTROL=/tmp/keyring-yVnSHj
:LANG=de_DE.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=rita
:HOME=/home/rita
:KEYTABLE=de-latin1-nodeadkeys
:LC_CTYPE=de_DE.UTF-8
:GTK_IM_MODULE=ibus
:QT_IM_MODULE=ibus
:XMODIFIERS=@im=ibus

event_log:
:2012-02-26-10:25:46> Analyzing coredump 'coredump'
:2012-02-26-10:25:47  All 17 debuginfo files are available
:2012-02-26-10:25:47  Generating backtrace
:2012-02-26-10:25:47  Backtrace is generated and saved, 11954 bytes
Comment 1 rita.heinrich 2012-02-26 04:28:34 EST
Created attachment 565866 [details]
File: maps
Comment 2 rita.heinrich 2012-02-26 04:28:36 EST
Created attachment 565867 [details]
File: backtrace
Comment 3 fujiwara 2012-02-28 20:33:28 EST
I cannot reproduce your g_assertion problem.
Are you still reproduce the same problem?


#0  0x0000003a90036285 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = <optimized out>
        selftid = 2285
#1  0x0000003a90037b9b in __GI_abort () at abort.c:91
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0}, sa_mask = {__val = {208264365890, 16360320, 208264384961, 4294967296, 32, 139890574590264, 16360320, 139890574590240, 139890574590240, 139890574508512, 139890574590240, 125, 1, 0, 208264280035, 16360320}}, sa_flags = 2105966330, sa_restorer = 0x41d907 <__dso_handle+31>}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x000000307d86841d in g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x41f940 "bus_dbus_impl_connection_filter_cb", message=0x7f3ad000dd60 "assertion failed: (connection != NULL)") at gtestutils.c:1425
        lstr = "1464\000\177\000\000\300:\244\336:\177\000\000@\031\000\330:\177\000\000\356\346A\000\000\000\000"
        s = 0x7f3ad00041e0 ""
#3  0x000000307d868942 in g_assertion_message_expr (domain=0x41d907 "IBUS", file=0x41e6e3 "dbusimpl.c", line=1464, func=0x41f940 "bus_dbus_impl_connection_filter_cb", expr=<optimized out>) at gtestutils.c:1436
        s = <optimized out>
#4  0x000000000040aff7 in bus_dbus_impl_connection_filter_cb (dbus_connection=<optimized out>, message=0x7f3ad00035e0 [GDBusMessage], incoming=1, user_data=0xf7a010) at dbusimpl.c:1464
        __PRETTY_FUNCTION__ = "bus_dbus_impl_connection_filter_cb"
        dbus = 0xf7a010 [BusDBusImpl]
        connection = 0x0
Comment 4 rita.heinrich 2012-02-29 12:35:22 EST
no. looks like a onedayfly. :)
Comment 5 fujiwara 2012-02-29 22:20:13 EST
Thanks.
Probably I won't be able to reproduce the issue.
If you will find the reproducing steps, please comment here.

Note You need to log in before you can comment on or make changes to this bug.