Bug 797576 - Update hwloc to latest stable upstream
Summary: Update hwloc to latest stable upstream
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hwloc
Version: 6.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Don Zickus
QA Contact: John Brier
URL:
Whiteboard:
: 757759 (view as bug list)
Depends On:
Blocks: 801095 788254 846704
TreeView+ depends on / blocked
 
Reported: 2012-02-26 20:42 UTC by Jiri Hladky
Modified: 2018-11-30 22:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:43:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 69435 None None None Never
Red Hat Product Errata RHBA-2013:0331 normal SHIPPED_LIVE hwloc bug fix and enhancement update 2013-02-20 20:54:23 UTC

Description Jiri Hladky 2012-02-26 20:42:38 UTC
Description of problem:

hwloc 1.4 is now available upstream. What are the plans to update hwloc in RHEL6?

I maintain hwloc package for Fedora and I can can make new package "hwloc14" available for EPEL6 if there are no plans to update hwloc in RHEL6. 
 

Thanks
Jirka

Comment 1 Don Zickus 2012-02-27 18:55:10 UTC
I can request an update for 6.4 and see if it gets approved.  I won't know for a few months though.

Cheers,
Don

Comment 2 Jiri Hladky 2012-02-29 23:05:40 UTC
Hi Don,

it sounds like a good plan. Please let us know the status once 6.4 is finalized.

Thanks 
Jirka

Comment 3 Don Zickus 2012-03-01 15:06:27 UTC
I will update this bz when I get new info.

Cheers,
Don

Comment 12 Don Zickus 2012-09-17 18:46:26 UTC
I have updated to v1.5 and will push that out to 6.4 barring any unforseen issues.

Cheers,
Don

Comment 16 Paul Needle 2012-10-11 14:35:36 UTC
*** Bug 757759 has been marked as a duplicate of this bug. ***

Comment 19 John Brier 2012-11-05 21:30:49 UTC
hwloc 1.5.1 was released on October 17th:

I am curious if we want to package that instead or stick with 1.5?

http://www.open-mpi.org/community/lists/hwloc-announce/2012/10/0045.php

 The Hardware Locality (hwloc) team is pleased to announce the release
of v1.5.1:

   http://www.open-mpi.org/projects/hwloc/

v1.5.1 is a bug fix release which addresses all known bugs in the
v1.5 serie.

* Fix block OS device detection on Linux kernel 3.3 and later.
  Thanks to Guy Streeter for reporting the problem and testing the fix.
* Fix the cpuid code in the x86 backend (for FreeBSD). Thanks to
  Sebastian Kuzminsky for reporting problems and testing patches.
* Fix 64bit detection on FreeBSD.
* Fix some corner cases in the management of the thissystem flag with
  respect to topology flags and environment variables.
* Fix some corner cases in command-line parsing checks in hwloc-distrib
  and hwloc-distances.
* Make sure we do not miss some block OS devices on old Linux kernels
  when a single PCI device has multiple IDE hosts/devices behind it.
* Do not disable I/O devices or instruction caches in hwloc-assembler output.

--
Brice

Comment 22 Jiri Hladky 2012-11-05 22:53:11 UTC
Hi,

I definitely agree that it makes sense to go for 1.5.1

I have updated master branch of hwloc for Fedora in case that anybody would like to test 1.5.1. My local tests all went through.

Jirka

Comment 23 John Brier 2012-11-28 20:59:52 UTC
Automated and manual testing succeeded

Verified.

Comment 25 errata-xmlrpc 2013-02-21 08:43:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0331.html


Note You need to log in before you can comment on or make changes to this bug.