Bug 7977 - Load keymap fails
Load keymap fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-23 15:53 EST by chris_tucker
Modified: 2014-03-16 22:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-18 11:59:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris_tucker 1999-12-23 15:53:55 EST
I want to use a UK keyboard mapping but the section of the rc.sysinit
script copied below does not work.
This is because it is run before the /usr partition has been mounted.
Therefore the test [ ... -d "/usr/lib/kbd/keymaps" ] always fails.
The solution is simply to move this whole section to later in the
script, after all partitions have been mounted read-write.

# Load keymap
KEYMAP=
if [ -f /etc/sysconfig/console/default.kmap ]; then
  KEYMAP=/etc/sysconfig/console/default.kmap
else
  . /etc/sysconfig/keyboard
  if [ -n "$KEYTABLE" -a -d "/usr/lib/kbd/keymaps" ]; then
     KEYMAP=$KEYTABLE
  fi
fi
if [ -n "$KEYMAP" ]; then
  # Since this takes in/output from stdin/out, we can't use initlog
  echo -n "Loading default keymap"
  loadkeys $KEYMAP < /dev/tty0 > /dev/tty0 2>/dev/null && \
     success "Loading default keymap" || failure "Loading default keymap"
  echo
fi
Comment 1 Bill Nottingham 2000-01-18 11:59:59 EST
This is fixed in 6.1; it will only load the keymap if it's
in /etc/sysconfig/console, and it will load it later in
the keytable init script.

Note You need to log in before you can comment on or make changes to this bug.