Bug 797720 - No search entry for "module=SOME_KERNEL_MODULE" in beaker web UI
No search entry for "module=SOME_KERNEL_MODULE" in beaker web UI
Status: CLOSED DUPLICATE of bug 590723
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.8
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-27 01:21 EST by Qian Hong
Modified: 2014-12-07 20:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-27 17:38:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qian Hong 2012-02-27 01:21:42 EST
Description of problem:

In beaker web UI, we can search machines matched by given key/value pairs.
However, there is no "module" key in the default key list.
Manually edit the url works, such as:


https://beaker.engineering.redhat.com/?systemsearch-0.table=Key%2FValue&systemsearch-0.keyvalue=module&systemsearch-0.operation=contains&systemsearch-0.value=cxgb3&Search=Search&systemsearch_column_System%2FArch=System%2FArch&systemsearch_column_System%2FModel=System%2FModel&systemsearch_column_System%2FName=System%2FName&systemsearch_column_System%2FStatus=System%2FStatus&systemsearch_column_System%2FType=System%2FType&systemsearch_column_System%2FUser=System%2FUser&systemsearch_column_System%2FVendor=System%2FVendor#

/* 
systemsearch-0.table
systemsearch-0.keyvalue=module
systemsearch-0.operation=contains
systemsearch-0.value=cxgb3
*/

The below XML code works as well:
<key_value key="MODULE" op="contains" value="cxgb3" />

It is strange to me that the "module" key is not included in the default key/value list in Beaker web UI.

Could this be fixed?

Thanks a lot!


Version-Release number of selected component (if applicable):
0.8.0

How reproducible:
100%
Comment 1 Dan Callaghan 2012-02-27 17:38:58 EST
Searches on "MODULE" were intentionally disabled in the web UI some time ago, to prevent users triggering this unresolved bug which kills our MySQL database:

https://bugzilla.redhat.com/show_bug.cgi?id=590723

*** This bug has been marked as a duplicate of bug 590723 ***

Note You need to log in before you can comment on or make changes to this bug.