Bug 79775 - 8.1 Beta2 - DiskOnKey is not recognized on hot insert
8.1 Beta2 - DiskOnKey is not recognized on hot insert
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-16 15:11 EST by Larry Troan
Modified: 2016-04-18 05:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-05 11:31:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (24.26 KB, text/plain)
2003-01-09 09:30 EST, Larry Troan
no flags Details
lspci (5.35 KB, text/plain)
2003-01-09 09:31 EST, Larry Troan
no flags Details
lsusb (27.25 KB, text/plain)
2003-01-09 09:33 EST, Larry Troan
no flags Details

  None (edit)
Description Larry Troan 2002-12-16 15:11:52 EST
Running 8.1beta2 on an upcoming nvidia chipset desktop system, the OS does not
recognize when a DiskOnKey has been inserted into the system.

Booting the system with the DiskOnKey in place will allow the system to
recognize and mount the device.

If the key is removed and then re-inserted into the same or another USB port,
the system can no longer recognize the device.
----------
Action by: ltroan
Believe this needs to be escalated to Bugzilla for Engineering to respond
directly. Will verify tomorrow.

ltroan assigned to issue for HP-ProLiant.
Category set to: Installer::Stage 2
Status set to: Waiting on Tech
Comment 1 Larry Troan 2002-12-16 15:13:11 EST
Escalated to Engineering per their request.
Comment 2 Alan Cox 2002-12-16 15:18:44 EST
Does the same disk on key device work on other random typical Linux PC systems.

Also need
Full dmesg including attach/remove/reattach
lspci -vxx
lsusb for each case

If its only happening on the Nvidia then we may be pushed to fix it due to
limited documentation.
Comment 3 Larry Troan 2002-12-16 15:22:15 EST
Ths is Issue Tracker 12406. 
Comment 4 Larry Troan 2003-01-02 21:28:56 EST
COMMENT FROM  ISSUE TRACKER per Marcg.Barber...
Have seen this same behavior on the next version of the intel desktop chipset as
well.

Comment 5 Larry Troan 2003-01-02 21:31:14 EST
REPEATING ABOVE ENGINEERING REQUEST FOR ADDITIONAL INFORMATION FROM HP....
Per Alan Cox on 12/16/2002...........
Does the same disk on key device work on other random typical Linux PC systems.

Also need
Full dmesg including attach/remove/reattach
lspci -vxx
lsusb for each case

If its only happening on the Nvidia then we may be pushed to fix it due to
limited documentation.
Comment 6 Larry Troan 2003-01-09 09:30:29 EST
Created attachment 89239 [details]
dmesg
Comment 7 Larry Troan 2003-01-09 09:31:28 EST
Created attachment 89240 [details]
lspci
Comment 8 Larry Troan 2003-01-09 09:33:51 EST
Created attachment 89241 [details]
lsusb
Comment 9 Larry Troan 2003-01-09 09:37:17 EST
Input from Marcg.Barber at HP (Issue Tracker)...did not get picked up by Bugzilla.
-----
Due to NDA, I am not able to give the requested information from a unit using
the nVidia chipset.  I have been able to reproduce this on a unit using the
older Intel 845GL chipset, and will attach the information requested using this
machine as a reference.
----
3 attachments included above.


Comment 10 Arjan van de Ven 2003-01-10 05:03:09 EST
/well since we can't test this; please try the rawhide kernel and check if USB
hotplug is fixed there..
Comment 11 Arjan van de Ven 2003-04-05 11:31:08 EST
closing due to inactivity in needinfo

Note You need to log in before you can comment on or make changes to this bug.