Bug 797773 - circular symlinks created in /lib64 (usrMove issue) for iptables-devel
circular symlinks created in /lib64 (usrMove issue) for iptables-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iptables (Show other bugs)
rawhide
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 743894
  Show dependency treegraph
 
Reported: 2012-02-27 04:34 EST by Andrew Elwell
Modified: 2012-03-06 15:44 EST (History)
4 users (show)

See Also:
Fixed In Version: iptables-1.4.12.2-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 15:44:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Elwell 2012-02-27 04:34:52 EST
Description of problem:
iptables-devel installs a circular link to libiptc.so, 
libip4tc.so, libip6tc.so

Version-Release number of selected component (if applicable):
iptables-devel-1.4.12.2-3.fc18.x86_64


How reproducible:
always

Steps to Reproduce:
1. yum install iptables-devel
2. readelf -Ws /lib64/libip4tc.so
3.
  
Actual results:
readelf: Error: Could not locate '/lib64/libip4tc.so'.  System error message: Too many levels of symbolic links


Expected results:
Listing of exported symbols

Additional info:
It looks like harald has already prepared a patch for this (and other hard coded path removal) at http://harald.fedorapeople.org/downloads/usrmove/iptables-usrmove.patch

It's related to the rawhide /lib64 -> /usr/lib64 move anyway. 

Main problem is in the .spec file 
-# create symlinks for devel so libs
-install -d -m 755 %{buildroot}%{_libdir}
-for i in %{buildroot}/%{_lib}/*.so; do
-    ln -s ../../%{_lib}/${i##*/} %{buildroot}%{_libdir}/${i##*/}
-done
-
-# move pkgconfig to %{_libdir}
-mv %{buildroot}/%{_lib}/pkgconfig %{buildroot}/%{_libdir}/
-

(I've got a similar patch to that of harald to work)
Comment 1 Petr Šabata 2012-02-28 09:10:34 EST
(In reply to comment #0)
> Description of problem:
> iptables-devel installs a circular link to libiptc.so, 
> libip4tc.so, libip6tc.so

And libxtables.so

Any progress?
Comment 2 Fedora Update System 2012-02-29 11:02:51 EST
iptables-1.4.12.2-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/iptables-1.4.12.2-4.fc17
Comment 3 Fedora Update System 2012-02-29 13:53:32 EST
Package iptables-1.4.12.2-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing iptables-1.4.12.2-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2700/iptables-1.4.12.2-4.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-03-06 15:44:38 EST
iptables-1.4.12.2-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.