Bug 797784 - file doesn't read patterns from $HOME/.magic.mgc file
Summary: file doesn't read patterns from $HOME/.magic.mgc file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: file
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Jan Kaluža
QA Contact: Karel Srot
URL:
Whiteboard:
Depends On:
Blocks: 847937
TreeView+ depends on / blocked
 
Reported: 2012-02-27 10:17 UTC by Karel Srot
Modified: 2012-10-31 09:44 UTC (History)
0 users

Fixed In Version: file-5.04-14.el6
Doc Type: Bug Fix
Doc Text:
Cause: File did not try to load magic patterns from ~/.magic.mgc. Consequence: Magic patterns stored in ~/.magic.mgc did not work. Fix: File now tries to load ~/.magic.mgc file. Result: If ~/.magic.mgc file exists on system, it's loaded and magic patterns defined in this file work as expected.
Clone Of:
: 847937 (view as bug list)
Environment:
Last Closed: 2012-10-04 12:21:32 UTC


Attachments (Terms of Use)
proposed patch (945 bytes, patch)
2012-08-07 05:56 UTC, Jan Kaluža
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1339 normal SHIPPED_LIVE file bug fix update 2012-10-04 16:15:20 UTC

Description Karel Srot 2012-02-27 10:17:43 UTC
Description of problem:

manpage says:
The information identifying these files is read from the compiled magic
file /usr/share/misc/magic.mgc, or the files in the directory
/usr/share/misc/magic if the compiled file does not exist. In addition,
if $HOME/.magic.mgc or $HOME/.magic exists, it will be used in preference
to the system magic files.

# cat > .magic
0 string ABCDEFGH Alphabet file
# echo ABCDEFGHIJ > testfile
# file testfile 
testfile: Alphabet file
# file -C -m .magic
# ls -l .magic.mgc 
-rw-r--r--. 1 root root 400 Feb 27 05:11 .magic.mgc
# rm .magic
rm: remove regular file `.magic'? y
# file testfile 
testfile: ASCII text


Version-Release number of selected component (if applicable):
# rpm -q file
file-5.04-11.el6.x86_64


How reproducible:
always


  
Actual results:
$HOME/.magic.mgc is ignored


Expected results:
$HOME/.magic.mgc is not ignored or the manpage is updated

Additional info:

Comment 2 Jan Kaluža 2012-08-07 05:56:04 UTC
Created attachment 602646 [details]
proposed patch

Comment 3 Jan Kaluža 2012-08-07 05:59:31 UTC
Upstream bugreport: http://bugs.gw.com/view.php?id=191

Comment 7 Jan Kaluža 2012-08-14 07:41:10 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: File did not try to load magic patterns from ~/.magic.mgc.
Consequence: Magic patterns stored in ~/.magic.mgc did not work.
Fix: File now tries to load ~/.magic.mgc file.
Result: If ~/.magic.mgc file exists on system, it's loaded and magic patterns defined in this file work as expected.

Comment 11 errata-xmlrpc 2012-10-04 12:21:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1339.html


Note You need to log in before you can comment on or make changes to this bug.